Unidentified Network problem with WPA2

Discussion in 'Windows 7 Networking' started by afmaster, Feb 16, 2010.

  1. afmaster

    afmaster New Member

    Joined:
    Feb 16, 2010
    Messages:
    8
    Likes Received:
    0
    Hello.

    I have a MSI wind Notebook 100U (Realtek wireless card) that connects perfectly in my WEP home network. It also connects nice with others WEP networks and with most cabled network. I had installed Windows 7 three month ago. When it ran Windows XP I had no problems to connect with WPA and WPA2. But in my job, the Wireless network runs WPA or WPA2 with TKIP encryption and now I can't connect anymore. I found a lot of similar problems, but none of them brings me the solution. I follow the administrator instructions:

    WAP2 - Enterprise; TKIP
    PEAP
    Unchecked the Server certificate box under configurations.
    Authentication methods: EAP-MSCHAP v2 and unchecked Windows username and password at the properties.

    This configurations were reviewed by the administrators and are OK. He also tried the WPA - Enterprise and It didn't work too.

    The message I received when I try to connect is "Unidentified Network" and I am not able to switch "local network" or access point among home, corporative and public networks. I have no access to the internet and no IP (just APIPA on "ipconfig /all").

    The administrator of the network is not dealing properly with this problems and a lot of Windows 7 users and some Windows vista users are facing the same problem than mine. Interesting is that some Windows 7 and vista users are connecting without problems. The XP computers and Iphone are working fine.

    I have tried:

    Updated my wireless card drivers.
    Disabled the IPv6.
    TCP/IP IPv4 is enabled.
    Network discovery is turned on.
    Printer and files sharing is enabled.
    Turned of all firewals (including the Windows one) and antivirus and antispywares.
    The Windows solution to vista problem I have tried on 7: DhcpConnEnableBcastFlagToggle on regedit (Windows Vista cannot obtain an IP address from certain routers or from certain non-Microsoft DHCP servers)
    On"services.msc", the DHCP client is started (but the logon is running on "this account" not in "local system account" because when I tried to put in this option my home network crushed).
    I didn't find Bonjour service in my computer. I didn’t install Itunes or other MAC programs.
    I also tested an USB Wireless card, without success. Therefore I think this is a Windows 7 bug.


    Some of the solutions will suggest to manually configure the DNS, IP number... But it is impossible to me argue with the wireless administrator in doing that. He explained to me a lot of reasons (that I didn't understand) why I cannot put an IP number manually.

    It is not my intent to be abrupt or discourteous. I apologize you for my English because I'm not an English expert. I hope you found the solutions. Thanks.
     
    #1 afmaster, Feb 16, 2010
    Last edited: Feb 16, 2010
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    It would seem that you have tried most of the things that I would suggest, the only other things you might try would be to make sure any third party firewalls and AV / Internet Security Suites are UNINSTALLED, it seems that often, disabling / turning them off doesn't seem to be enough. You can always put them back on later.

    Also sometime when you install a WiFi driver package you get the manufacturer's management utility with it and Windows 7 doesn't seem to play nice with some of these so if you have something like this installed you might try uninstalling it.

    As a final last ditch attempt at diagnosing the problem, perhaps booting the machine in safemode with networking, assuming that the drivers for your wireless adapter will load in safemode with networking this would help eliminate most third party software and services as being the culprit.

    Also you might check in the properties of your Wireless Adapter, click the configure button and then the advanced tab, see if there is anything in there, especially if it's an "N" adapter, that might let you dumb it down to "G", I have heard that some N cards have issues with WPA2, but I'm not sure what you options might be.
     
  3. afmaster

    afmaster New Member

    Joined:
    Feb 16, 2010
    Messages:
    8
    Likes Received:
    0
    Becoming Hopeless

    I already have unistalled my antivirus (avira). This modification didn't work. I think this problem is related to the Windows firewall itself. I don't know how but it seems to be a bug in the firewall that prevents you to connect in some DHCP servers. I don't have enough Knowledge to totally disable the Windows Firewall.

    I think this is not a problem related to the WiFi driver or related to the wireless adapter because since I installed the Windows Seven with the drivers purchased by Windows updater itself I cannot connect in the Wireless of my job. When I updated the recents (january 2010) drivers from the manufacturer's website the problem persists. Furthermore I have tested my connection with an USB wireless card that is used by the WLAN administrator of my Job. This Card is working with other operational systems... But I'll check this information.

    Booting the machine in a safe mode with networking is a good idea. Here in Brazil is a carnival holiday. So I can only do this test tomorrow. But I'll let you know.

    I checked in properties of my Wireless Adapter then in advanced tap and found this:
    802.11 d - Disable
    Channel - 10
    Fragmentation Threshold - 2346
    IBSS Default 11b Mod - Disabled
    Network Type - Infrastructure
    Power Safe Mode - CAM
    Preamble Mode - Auto
    QoS - Disable
    Rate Adaptive - Enable
    RTS Threshold - 2347
    SSID - Any
    IEEE 802b/g (This is the optionon that is set) or IEEE 802.11b (This is the other option wich is not chosen).
    I don't understand N or G. May you tell me more about this?

    I'm gratefull for your regards. Excuse my english.
     
    #3 afmaster, Feb 16, 2010
    Last edited: Feb 16, 2010
  4. afmaster

    afmaster New Member

    Joined:
    Feb 16, 2010
    Messages:
    8
    Likes Received:
    0
    None of my trials have been worked. I will continue to wait for other opinions and other users who are facing the same problem. Thanks.
     
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Do you have a wireless router at home that you could experiment with by adjusting the security on your own router just for testing and to make sure that the problem is actually your adapter and not something else. It seems you mentioned that it runs fine "at home" using WEP, does your wireless router "at home" support higher levels of encryption like WPA and WPA2, if so you can do your own local testing to see if the problem is WPA or WPA2. If the problem persists, you may have to invest in another wireless adapter (or borrow one temporarily) to see if it's specific to your particular device
     
  6. afmaster

    afmaster New Member

    Joined:
    Feb 16, 2010
    Messages:
    8
    Likes Received:
    0
    I realy appreciate your values suggestions but I think this is not a card adapter problem cause I tried external wifi adpter and It didn't work in windows 7. That external wifi USB adapter worked fine with XP computers. Most of seven users are facing the same problem as mine (including another WPA2 lans over the World like I saw in a lot of foruns). My home Wireless Router is a D-Link DI-524. It has WPA option. But I don't Know how to create a WPA LAN and I have a fear to mess my home LAN. Morover the job Wireless network is a WPA2-Enterprise not a simple WPA.
    Again, thanks for your advices. Henceforth I'll wait for Microsoft updates and for my job wireless administrator to solve this problem. I propose to him to make a simple WEP LAN but He is afraid with security issues. The WEP LAN can connect more easily all computers. The security problem can be solved by making a proxy resgistry before navigate in the internet. None user can navigate to the internet without logging in the proxy server.
    If none of this measures works, I'll try to reinstall seven. Even after reinstallation I cannot connect, I'll reinstall XP untill Microsoft corrects this version of Windows Seven.
     

Share This Page

Loading...