Updating Network Driver?

Discussion in 'Windows 7 Networking' started by d1ey0u, Dec 13, 2009.

  1. d1ey0u

    d1ey0u New Member

    Joined:
    Dec 13, 2009
    Messages:
    4
    Likes Received:
    0
    Hello everyone, I have just joined this forum in search of further understandings of Windows 7. I have just recently installed Windows 7 on my Toshiba Laptop and am having some troubles. I have no idea how to view wireless connection. I go to the Network and Sharing section of Control Panel and don't see anything about wireless. I have some ghetto router named a AirLink 101, but I have never had problem with it and my laptop untill 7 was installed. Someone suggested I update my drivers? So I went to device manager and saw a yellow exclamation mark. It's under the Other Devices tab and it is right next to Network Controller. Does that mean there is an error with that driver? Anyway since I am not good at this kind of stuff maybe you can help me?? I need to know how I can update driver and who manufactured it.

    Also, I saw several topics about my other problem but mine seems a bit different. After a couple hours go by with stable internet connection it stops. My other pc's are still connected, all running Windows Vista. Then my laptop says that another computer is using the ip address and can have cause problems. When it happens again I will post exact words. xD Anyway, it is very annoying!!!! Other then that I LOVE Windows 7!!
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Without knowing which Toshiba laptop you have (model name and number), I don't believe we can help much with your first problem. You can check with Toshiba's site and see what they have available for your particular model in their support and drivers section go here and click the download link at the top and select your laptop http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/home.jsp# You also didn't say whether of not you are running the 64bit version of Windows 7, as you can see, some of their laptops need a bios update to support that version. Your second problem is probably caused by a device on your network with a static IP address that is within the same scope that whatever is hosting DHCP service is handing out on your network. You can either change all your devices to static ip address, or all to automatically receive IP address from a DHCP server, or adjust your DHCP server's scope to excluded statically assigned address, once you determine what they are
     
    #2 Trouble, Dec 13, 2009
    Last edited: Dec 13, 2009
  3. d1ey0u

    d1ey0u New Member

    Joined:
    Dec 13, 2009
    Messages:
    4
    Likes Received:
    0
    Okay, I will take a look at the Toshiba link and see what I can find.

    As for the ip address part, I have a password on my wifi..... And I assigned different ip addresses on the 3 computers in my network. How is there a problem? I checked many times. Hmmm Any other ideas?

    And thanks for the reply. :D
     
  4. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Totally agree Trouble

    Could you please fill in your computer specs in the UserCP link at the top left hand side of the page.

    Then click Edit Your Details.

    This freeware program will give you all the information you will need:

    SIV (System Information Viewer) 4.03
     
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Yep...if there is one thing I'm not usually short of, it's ideas. The only problem is their not always good ones. My suggestion would be, that if you are always going to assign (static) ip addresses to ALL the devices on your network, then turn off DHCP on your router, I'm not at all familiar with the AirLink 101, but it probably has a browser interface and an option somewhere within that to disable DHCP, however, and I warned you that their not always good ones, this is not ideal if you have a lot of friends and relatives stopping by and wanting to use your wireless network. Another suggestion would be to set it up so that DHCP was only handing out 8 or 10 addresses, somewhere up high like .243 to .253 or somewhere down low like .10 to .20 which ever is less likely to conflict with addresses that you statically assign.
     
    #5 Trouble, Dec 13, 2009
    Last edited: Dec 13, 2009

Share This Page

Loading...