Upgraded to Windows 8 and Now Internet Problems

I have a Dell Latitude E6500. Before tonight, I was running Windows 7. I decided to update to Windows 8 and now I am unable to get any web pages to load. My wireless is connected but no pages will load when I open IE.

I can't imagine I am the only one who has run in to this. Any help would be greatly appreciated.

Maybe it's a device driver; but I can't get to the Dell site to do any diagnostics.

Thank you in advance for all the help!



Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
Hi Bob,

After upgrading did you install your drivers etc? If not you can find them here although you'll have to use win 7 versions. If anything seems like it doesn't want to install, try compatibility mode:

Drivers and Downloads | Dell [United States]

Did you do an upgrade or a clean installation of Windows 8? Have you tried if you have internet access by using direct cable (if possible)? Are you connected to the correct SSID network? (I've noted that Windows 8 connects a lot easier to unprotected networks then prefered networks on occasions)...

Hi tdkbe,

I did an upgrade. I have tried both wireless and direct (wired) connection and neither work.

Go to the M/B's web site @ look for Ethernet driver. Try an external card.


May sound silly but have you tried rebooting your internet modem/router? The odds that you like drivers for both network adapters seems not that high. Do you receive an correct IP address while connecting (if not using fixed) or do you get one in the range 169.x.x.x? Is the gateway/DNS also correctly set/received?

Last edited by a moderator:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.