wifi connected, but no internet connection

Discussion in 'Windows 7 Networking' started by dellic sekunde, Jan 1, 2012.

  1. dellic sekunde

    dellic sekunde Well-Known Member

    Joined:
    Jan 1, 2012
    Messages:
    19
    Likes Received:
    0
    Hello all, I found similar topics but not solution for mine, please help.

    I connect to my home wifi and it says connected, but there is no internet connection.
    I noticed that network adapter shows "wireless network connection 2" with that "2" at the end of name. I guess there is a problem. If I rename it to just "wireless network connection" it says it already exists. But cannot see it, and use it! Can anyone tell me how to reset it or somehow switch to "wireless network connection" without "2"?

    Also when I type ipconfig/all I get this:
    ------------------

    C:\Users\user>ipconfig/all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : user-PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Wireless LAN adapter Wireless Network Connection 2:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Dell Wireless 1510 Wireless-N WLAN Mini-C
    ard
    Physical Address. . . . . . . . . : 90-4C-E5-3F-2B-C6
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::7d98:b6f0:76fb:6f9e%15(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.1.5(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : 01 January 2012 16:46:53
    Lease Expires . . . . . . . . . . : 02 January 2012 19:09:45
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DHCPv6 IAID . . . . . . . . . . . : 345001189
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-98-7F-6C-00-25-64-74-D4-2B

    DNS Servers . . . . . . . . . . . : 192.168.1.1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection 2:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom NetLink (TM) Gigabit Ethernet
    Physical Address. . . . . . . . . : 00-26-B9-0F-25-85
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{2947BA03-3327-4E65-B736-14FB1ACB83E9}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{7A2DD197-2CE7-4C78-B3DD-8862AE57AE09}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fd:8eb:30a4:3f57:fefa(Prefe
    rred)
    Link-local IPv6 Address . . . . . : fe80::8eb:30a4:3f57:fefa%18(Preferred)
    Default Gateway . . . . . . . . . : ::
    NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter 6TO4 Adapter:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft 6to4 Adapter #3
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    ----------------

    thanks in advance!
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Hello and welcome to the forum. Give this a try first and see if your problem can be resolved using this method;
    Evidently the driver (new versions) default to setting the "BSS Mode" to 802.11n and some have found that changing that setting to 802.11g has resolved their issues. So....
    Go back into device manager
    expand network adapters
    select then right click the problem wireless adapter and choose properties
    select the "Advanced" tab at the top
    In the left column titled "Property:" see if you have a BSS Mode listed. If so select it and in the right column titled "Value:" use the drop down arrow to change from 802.11n to 802.11g
    OK your way back out of there and reboot and see if that helps.
    Regards
    Randy.
     
  3. dellic sekunde

    dellic sekunde Well-Known Member

    Joined:
    Jan 1, 2012
    Messages:
    19
    Likes Received:
    0
    Hi Randy, many thanks for prompt reply!
    I did as you said, restarted comp, but still no progress. Wireless net connecton is named with "2" and "no internet access" :( any more ideas?
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    First of all the name of the connection should have nothing to do with your ability to access the internet at all. You could rename it GreenRedAndPurple and it shouldn't mean anything at all other than just a name. Since I have multiple simultaneous connections I typically rename them with my static IP address assignments just so I know which one I'm dealing with.
    Having said that, you seem to be getting at least logical IP addressing from your DHCP server (Wireless Router) so we are stuck with figuring out why or if you are not resolving FQDNs (Fully Qualified Domain Names).
    So could you please open your browser (which one do you typically use by the way?)
    and type 209.85.145.105 into the URL address bar (not the search bar) and hit enter.
    Does Google come up?
    The problem could be either
    Your host files
    A blackhole proxy server or
    Your router is not forwarding DNS queries reliably.
    Shut down your network first (computer, router (remove power), ISP provided device (remove power and battery if present). Let everything sit for a few minutes. Restart your network in reverse order ISP provided device (replace battery and plug it back in) wait until all lights are stable, then your router (plug it back in) wait till all lights are stable, then your computer. See if recycling the network helps at all. Check your host here C:\Windows\System32\drivers\etc\hosts you can open it with notepad, it should look like this
    Code:
    # Copyright (c) 1993-2009 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    #      102.54.94.97     rhino.acme.com          # source server
    #       38.25.63.10     x.acme.com              # x client host
    
    # localhost name resolution is handled within DNS itself.
    #    127.0.0.1       localhost
    #    ::1             localhost
    Check for a blackhole proxy server in IE9 by click the little gear looking symbol icon under the Red X and choosing Internet Options Select the Connections Tab and then the LAN settings button
    Uncheck all the check boxes and OK your way back out of there. Close and reopen IE9
    If the problem is that your router is not forwarding DNS queries reliably try adding your ISP's DNS server addresses into the properties of your network adapter under the properties of IPv4.
     
    #4 Trouble, Jan 1, 2012
    Last edited: Jan 1, 2012
  5. dellic sekunde

    dellic sekunde Well-Known Member

    Joined:
    Jan 1, 2012
    Messages:
    19
    Likes Received:
    0
    Hi. No Google when I typed that IP. When opened host in notepad it's same as your example. No help from IE9, and I tried to manually enter DNS number... I suppose it's my rooter problem. Cause I can attach to wireless network to my friend's house and other... just that one I make doesn't work. And strange is, it worked 2 weeks ago, and before that didn't. I can't figure out what's reason sometimes it works and sometimes not, though I never changed any settings.
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    I didn't understand or quite get that piece of information from your OP.
    That symptom is most often caused by a small third party program called mDNSresponder.exe.
    Open taskmanager (right click taskbar and choose Start Task Manager)
    Select the processes tab and click the button at the bottom that says Show processes from all users
    See if you have mDNSresponder.exe running and let us know.
    Regards
    Randy
     
  7. dellic sekunde

    dellic sekunde Well-Known Member

    Joined:
    Jan 1, 2012
    Messages:
    19
    Likes Received:
    0
    Hi, I have checked out, there is no such program. Sorry, I didn't know that info could also help. Anyway, at the first time one IT guy set me that network, it worked for some period than: not/did/not (current situation). Also, maybe this could help: I don't have classic rooter I share Internet connection via airport from Imac to this Dell laptop. And I never made any changes to settings since the first time it worked well. Every time I want to share Internet to laptop I generate new network (wep 40), set new name for it and password. Always the same steps. Just, from time to time it stops working, actually it connects but no Internet access.
     
  8. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Take a look at this How To Share The Internet Connection Between Mac and PC
    note his comments concerning 40 versus 128 bit WEP encryption, also his comments about 13 character password and renaming the network to something really short (probably 8 character or something less than 11) with no spaces in name.
    I have no idea how a Mac handles Internet Connection Sharing, but I know that the IP addressing scheme in your OP is not typical of an ICS client in a Windows/Microsoft environment, but MAC may be completely different and that may not be a particularly significant observation.
     
  9. dellic sekunde

    dellic sekunde Well-Known Member

    Joined:
    Jan 1, 2012
    Messages:
    19
    Likes Received:
    0
    :frown: I tried 128 bit WEP encrypt, no results... and to generate network from mac - from the beginning. Although, this is explanation for Win XP I believe it should work with 7 also.
     
  10. dellic sekunde

    dellic sekunde Well-Known Member

    Joined:
    Jan 1, 2012
    Messages:
    19
    Likes Received:
    0
    If you know any more resources/articles about this topic, please forward. Thanks!
     
  11. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    There are probably any number of articles you can find relating to what you are trying to do but not much in the way of troubleshooting them when they don't work as explained.
    Share Mac Internet with PC, iPhone, iPad, iPod, Windows 7, other Wireless Devices | Mac OS X
    You may want to open the network and sharing center on the Windows 7 machine and in the left column select manage wireless networks and remove any and all profiles, then close the network and sharing center and click the network icon in the notification area and see if you can rebuild the connect again from scratch.
    Regards
    Randy
     
  12. dellic sekunde

    dellic sekunde Well-Known Member

    Joined:
    Jan 1, 2012
    Messages:
    19
    Likes Received:
    0
    Didn't find solution yet, but thanks for all help anyway. If I happen to solve problem, I'll let you know
     
  13. dellic sekunde

    dellic sekunde Well-Known Member

    Joined:
    Jan 1, 2012
    Messages:
    19
    Likes Received:
    0
    Hello, got some good news. Network works again! Here is what I did:
    - I turned off Internet sharing on iMac and keep it off for some time
    - updated Windows. I do it on regular basis, automatic updates are turned on
    - created new network via Airport, WEP-40, short name, and Windows got it!

    No manual set-ups or setting changes. Just as it was before this problem. Thanks again!
    Cheers :D
     

Share This Page

Loading...