"WiFi" doesn't have a valid IP configuration

#1
I bought a new lenovo laptop with built-in windows 8 OS. Just after a few days I started using it, networking problems arose. When I tried to connect to a wireless router,it shows connected but could not browse even. Troubleshooting gives a message that "WiFi does not have a valid IP configurations" or "Problem with wireless adopter and access point" or "Network cable is not properly plugged in".
I contacted Lenovo chat support and tried re-installing the latest drivers, but couldn't solve the problem. i still couldn't connect to the wireless network properly. Thanks.
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#2
Goto programs, run command prompt and enter in the command window:

ipconfig /all

Show the output here if you need help with it.
 


#3
thanx for ur reply. here are the details...





Windows IP Configuration


Host Name . . . . . . . . . . . . :
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No


Wireless LAN adapter Local Area Connection* 12:


Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
Physical Address. . . . . . . . . : 9C-4E-36-78-48-7D
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes


Ethernet adapter Bluetooth Network Connection:


Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
Physical Address. . . . . . . . . : 20-68-9D-7A-98-D8
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes


Ethernet adapter Ethernet:


Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
Physical Address. . . . . . . . . : 08-9E-01-34-36-4B
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes


Wireless LAN adapter Wi-Fi:


Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) Centrino(R) Wireless-N 2200
Physical Address. . . . . . . . . : 9C-4E-36-78-48-7C
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::740c:bcd7:eddd:af45%12(Preferred)
IPv4 Address. . . . . . . . . . . : 172.16.51.124(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Lease Obtained. . . . . . . . . . : 14 March 2013 21:30:09
Lease Expires . . . . . . . . . . : 15 March 2013 07:14:11
Default Gateway . . . . . . . . . : fe80::2c10:39d8:a485:8ea%12
fe80::30e8:1ead:79ce:44dc%12
172.16.48.1
DHCP Server . . . . . . . . . . . : 172.16.48.1
DHCPv6 IAID . . . . . . . . . . . : 261901878
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-17-B3-8C-9C-4E-36-78-48-7C
DNS Servers . . . . . . . . . . . : 172.16.48.1
NetBIOS over Tcpip. . . . . . . . : Enabled


Tunnel adapter isatap.{7FB24A4C-B989-49F5-B27A-AD2024A0AC07}:


Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes


Tunnel adapter Local Area Connection* 14:


Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft 6to4 Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes


Tunnel adapter Teredo Tunneling Pseudo-Interface:


Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:9d38:6ab8:24b4:1b93:53ef:cc83(Preferred)
Link-local IPv6 Address . . . . . : fe80::24b4:1b93:53ef:cc83%19(Preferred)
Default Gateway . . . . . . . . . : ::
DHCPv6 IAID . . . . . . . . . . . : 570425344
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-17-B3-8C-9C-4E-36-78-48-7C
NetBIOS over Tcpip. . . . . . . . : Disabled
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#4
In this section which I have copied from your wireless adapter configuration:

Wireless LAN adapter Wi-Fi:


Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) Centrino(R) Wireless-N 2200
Physical Address. . . . . . . . . : 9C-4E-36-78-48-7C
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::740c:bcd7:eddd:af45%12(Preferred)
IPv4 Address. . . . . . . . . . . : 172.16.51.124(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.255

The subnet mask needs to be 255.255.0.0

I see that you have the adapter set to use DHCP which means that the router sahould automatically set this for you. As it has not it would appear that the router is not running DHCP. You need either ro get the router set to run DHCP or you need manually to change the subnet mask to the value I have indicated, ie: 255.255.0.0
 


#5
Some times this type of issue arises when the network stack has been corrupted. How and why is still a mystery to most of us. Generally a reboot of the router will fix this by unplugging the router from the AC outlet for 2 minutes and then plugging it back in. On extreme situations a router reset is needed. Which resets the router back to factory settings. To do this you'll need a paper clip straightened out, on the back of the router there will be a tiny hole, insert paper clip into the hole, push and hold down reset button until the router turns off, then remove paper clip and let router boot up. This will change all settings of the router and rebuild the network stack. So you are using wireless with the router you will have to set up all the security settings.
 


#6
thanx dude after a long struggle down solve the problem...
thanQ 1ce again!!!

In this section which I have copied from your wireless adapter configuration:

Wireless LAN adapter Wi-Fi:


Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) Centrino(R) Wireless-N 2200
Physical Address. . . . . . . . . : 9C-4E-36-78-48-7C
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::740c:bcd7:eddd:af45%12(Preferred)
IPv4 Address. . . . . . . . . . . : 172.16.51.124(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.255

The subnet mask needs to be 255.255.0.0

I see that you have the adapter set to use DHCP which means that the router sahould automatically set this for you. As it has not it would appear that the router is not running DHCP. You need either ro get the router set to run DHCP or you need manually to change the subnet mask to the value I have indicated, ie: 255.255.0.0
 


#7
thanQ 4 ur intrest...
if i face the problem again in future(hope not), definitely i'll try this
thanQ

Some times this type of issue arises when the network stack has been corrupted. How and why is still a mystery to most of us. Generally a reboot of the router will fix this by unplugging the router from the AC outlet for 2 minutes and then plugging it back in. On extreme situations a router reset is needed. Which resets the router back to factory settings. To do this you'll need a paper clip straightened out, on the back of the router there will be a tiny hole, insert paper clip into the hole, push and hold down reset button until the router turns off, then remove paper clip and let router boot up. This will change all settings of the router and rebuild the network stack. So you are using wireless with the router you will have to set up all the security settings.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.