Win 7 can't install drivers for optical drives

Discussion in 'Windows 7 Hardware' started by scandib, Feb 6, 2009.

  1. scandib

    scandib New Member

    Joined:
    Feb 6, 2009
    Messages:
    14
    Likes Received:
    0
    I have two optical drives, a Sony CD-RW CRX320EE ATA CD-RW drive, and a Samsung (TSST) CDDVDW SH-223F DVD-RW drive. The Sony is a bit old, but the Samsung is brand-new. Both worked fine under Vista. Neither manufacturer supplies downloadable drivers for these, since they're plug and play, and the OS is supposed to recognize them automatically. I've uninstalled them in Device Manager and rebooted, whereupon Windows tries to install but fails. I get the message "Device driver software was not succesfully installed."

    I have no clue what else to do. Don't really want to go back to Vista, but these are critical devices. Any ideas? Thanks!

    BTW, running 64-bit on Intel Core duo, DP35DP mobo, 4 MB RAM.

    Also, one of the error messages in Device Center claims that "Windows cannot verify the digital signature for the drivers required for this device." Not sure what to do about that. And the drivers already installed for these (the same ones that were installed under Vista) are just the basic MS driver, dated 6/21/2006, that every other CD/DVD drive in the world has. Digitally signed by Microsoft, no less.
     
    #1 scandib, Feb 6, 2009
    Last edited: Feb 6, 2009
  2. JustDavid

    JustDavid New Member

    Joined:
    Jan 11, 2009
    Messages:
    36
    Likes Received:
    1
    You might try this:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11­CE-BFC1-08002BE10318}

    Apparently it seems that this is an age old fix for even XP systems. If you venture to the registry key above by doing the following steps:
    1. Click on the start menu.
    2. In the search box type in “regeditâ€Â￾ without the quotation marks.
    3. Maximize the HKLM and then go ahead and browse until you reach the key listed above.
    4. In the right panel you’ll see something along the lines of “UpperFilterâ€Â￾ and “LowerFilterâ€Â￾ you want to click on each “filterâ€Â￾ key and hit delete. Click yes when it asks to confirm if you wish to delete the key.
    5. Exit regedit.
    6. Go to Device Manager and delete the CD/DVD drive then rescan for hardware changes. The CD/DVD should redetect.
    As always, no warranty is implied here, and you edit the registry at your own risk. You might want to make sure you have a good backup prior to doing any registry editing.

    Good luck and let us know if this was the problem.
     
  3. scandib

    scandib New Member

    Joined:
    Feb 6, 2009
    Messages:
    14
    Likes Received:
    0
    Thanks much for your reply. Shortly after posting, I found a similar answer on another forum. And sure enough, it worked fine. This was indeed the problem. All is well.

    It's amazing to me that this has been around since XP days!

    Saul
     
  4. ObsidianShocker

    ObsidianShocker New Member

    Joined:
    Nov 4, 2009
    Messages:
    30
    Likes Received:
    0
    Raid 0 ?

    hello i too own the DP35DP mobo and am having issues with alot of things right now. i am wondering if you have a raid 0 setup with your dp35dp i recently updated the bios and am getting a black screen after having raid 0 setup working in 64 bit windows 7 mode. updating the bios was supposed to fix my HD not being recognized but i believe someone else pointed out the correct solution for this. 8.8 matrix manager. i am currently waiting for my bios to be reset aka removed the battery at this point. will try again fresh install
    raid 0 Window 7 64bit with an
    Intel dp35dp motherboard
    Intel core 2 duo chipset 2.33Ghz
    6 gigs of DDR2 ram
    8800GTS Nvidia card
    4 HD two sata 80gigs and 2 Sata 500gig drives. both setup as raid 0
     
    #4 ObsidianShocker, Nov 4, 2009
    Last edited: Nov 9, 2009

Share This Page

Loading...