Windows 10 - on restart opens programs from last session

Philip P

New Member
Hello.

I have recently upgraded to Windows 10 Creators and have noticed that when i turn my PC on it opens all the programs and webpages that i had open during my last login session.

For example yesterday morning, i had internet explorer, chrome and Edge all open at different webpages, plus File explorer and a couple of other programs. When i had finished I hit the power icon and chose Shut Down (same as i have done for years). Last night when i turned the PC back on everything i had open in the previous session started to load up again with all the browsers opening all the webpages i had opened earlier that day.

I have checked the startup tab on task manager and none of the programs which open are listed and now im at a bit of a loss.

Would anyone know how to start every login fresh with just your desktop showing - i.e. that Windows 10 doesnt remember what i was doing in the last session and open everything up again?

Thanks for your help

Philip
 

nmsuk

Windows Forum Admin
Staff member
Premium Supporter
Have that issue myself and it's been driving me mad trying to fix it.
 

kemical

Windows Forum Admin
Staff member
Premium Supporter
Would anyone know how to start every login fresh with just your desktop showing - i.e. that Windows 10 doesnt remember what i was doing in the last session and open everything up again?
Personally i just shut everything down which also has the added bonus of your machine shutting down faster. I've always done this however so it's not a big deal for me. I can imagine that if one is used to simply turning the machine off with all sorts of apps and tabs open that it could be frustrating but so far it's the only fix I know.
 

pnamajck

Honorable Member
incidentally, the feature you described is available on the latest models of mac-os.

what i believe is happening to your computers … it is "hibernating" rather than shutting down. in order to circumvent this feature … simply disable "fast startup" (hybrid-shutdown).

Why Is Windows Hibernating Instead of Fully Shutting Down?
and if needed: hibernate instead of shutdown win-10 - Google Search

the following are only similar settings which may/mayn't assist you … you probably won't need the info … but i decided to include anyway.

for win-10 … if you hit the power-button to shutdown your computer … there is an option to "hibernate" rather than shutdown. and, if the computer enters into hibernation … this is not a "sleep" type of hibernation … this will shut down the computer … and, upon next boot-up, the programs that had been open just before shutdown will reopen.

scenario #1:
to get to this option … control-panel / power-options / change-plan-settings (edit-plans) / advanced /
Image1.png

scenario #2:
to get to this option … control-panel / power-options / choose what power-button-does (system-settings) / advanced /
Image2.png

scenario #3:
and, if shutdown-settings is greyed out … in same interface, "change settings that are currently unavailable".

of course … create a system-restore-point … in the event something goes wrong. it should be noted … the reference offered below only explains what the hibernation feature does … the remainder of the content in this post was by me investigating my own environment.

ref:
How to make Windows start up with your last-used programs and websites already open
 
Last edited:

kemical

Windows Forum Admin
Staff member
Premium Supporter
If you do try pnamajck's tip just remember that turning this feature off will make booting from cold slightly slower (just in case your wondering why it's slowed down on a cold boot.. ;) )
 

Neemobeer

Windows Forum Team
Staff member
This isn't due to hibernate.

I've confirmed the setting re-opening windows is the following
  • Press [windows key + i]
  • Select Accounts
  • Click on 'Sign-in Options'
  • Scroll to the bottom and turn off 'Use my sign-in info to automatically finish setting up my device after an update or restarty'
 

petmike

New Member
Hello.

I have recently upgraded to Windows 10 Creators and have noticed that when i turn my PC on it opens all the programs and webpages that i had open during my last login session.

For example yesterday morning, i had internet explorer, chrome and Edge all open at different webpages, plus File explorer and a couple of other programs. When i had finished I hit the power icon and chose Shut Down (same as i have done for years). Last night when i turned the PC back on everything i had open in the previous session started to load up again with all the browsers opening all the webpages i had opened earlier that day.

I have checked the startup tab on task manager and none of the programs which open are listed and now im at a bit of a loss.

Would anyone know how to start every login fresh with just your desktop showing - i.e. that Windows 10 doesnt remember what i was doing in the last session and open everything up again?

Thanks for your help

Philip
 

petmike

New Member
My issue is this: Every time I open Chrome, it opens my home page, plus all the tabs I had open when I closed it last. It used to open only ONE specifically listed home page, but now it opens all the last set of pages that were open when I closed it. This just started happening a few weeks ago. I have "open a specific page or set of pages" checked under the On Startup section, and it lists only one specific page.
Version 63.0.3239.84 (Official Build) (64-bit)
 

Neemobeer

Windows Forum Team
Staff member
If you leave chrome open and shut windows down I believe it Chrome will try and restore your open pages.
 

petmike

New Member
If you leave chrome open and shut windows down I believe it Chrome will try and restore your open pages.
I close Chrome first before logging out of Windows. Then when I open Chrome after logging into Windows the next time I log into my desktop, Chrome reopens all the last tabs not just the one designated by my startup choice.
 

petmike

New Member
Yes, but not any newer ones. Nothing changed when this all started happening in Chrome. It seemed to happen after Windows upgraded.
 

Neemobeer

Windows Forum Team
Staff member
If you're on the 1709 build (fall creator) try the following
  • Press [Windows key + i]
  • Click on Accounts
  • Click on Sign-in options
  • Turn off "Use my sign-in info to automatically finish setting up my device after an update or restart"
 

petmike

New Member
Yes, build 1709.

Now when I try opening and closing Chrome, it seems to be working correctly again. Perhaps Google fixed the issue. If it happens again, I'll try what you suggest. Thanks.
 
Top