Windows 7 administrator but dont have privilege like uninstall, viewing services.msc

I bought a brand new laptop a week ago. It was loaded with windows 7 professional. When I switched on for the first time it didnt have any user account. So I have created an account for myself as administrator user account. Say 2 or 3 days back I have downloaded GTalk and other softwares and installed it using this account. Today when I wanted to uninstall one of the softwares it was showing a popup saying that I dont have system privileges to uninstall the product. I tried to uninstall some other softwares and was shown the same message. I went to control panel and there with my photograph it showed under my username that I am an administrator. But when I wanted to manage my account it was doing nothing when I clicked manage link. Also the same case when I clicked change account type. Two account I have created, one for me and one for my wife. Both I have created as administrator accounts. Now both the accounts are showing as administrator accounts but was not allowing to uninstall. I tried to open eventvwr. But still the same message.

Say 2 days before I wanted to give permission to one of my folder. So I have removed all the permissions to all other users and have given my user full permission. But it was not allowing me as there was some conflict in inherited permissions. So I removed inheriting permission. But I didnt see that it was going to reflect the permission through out C: where my folder resides. But I cancelled the operation in between.

Does this has got any link with my admin issue. Even then I have given my user with full permissions.

My hard drive has got only one drive that is C: where OS is also installed. My HDD total space is 470 GB and total 470 GB was allocated to C: drive itself.

Please help me to get my admin rights back in my laptop. Without which I am not able to do much of work !!

Welcome to the forums, Jeyaraman.

If you cannot uninstall through Control Panel > Programs and features > Uninstall programs, try these steps:

1. Find the uninstaller within the software group folder in the start menu, or navigate to C:\Program Files [or C:\Program Files (x86)]\ to the software folder and try to find the uninstaller.exe.

2. Right click on the uninstaller and run it as administrator


If it still blocks the uninstall process, try enabling the hidden Windows 7 built-in administrator account :

Enable the (Hidden) Administrator Account on Windows 7 or Vista - the How-To Geek

Run command prompt as admin => type in net user administrator /active:yes => you should see a message that the command completed successfully => Log out and then log in to the Administrator account => Try to uninstall now.

Use the built-in Administrator account in critical situations only, do not use it as your default user account. To turn it on, type in the commasnd prompt net user administrator /active:no


You can also use these freeware tools:

CCleaner - Home
Download Revo Uninstaller Freeware - Free and Full Download

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.