Windows 7 corrupts Floppy disk

#21
...blah

To resolve this problem, re-format the floppy disk with Windows 98, Windows Mill...
To resolve this problem, re-format the floppy disk with Windows 98, Windows Millennium Edition, Windows NT, Windows 2000, Windows XP, or Windows Server 2003.

that does not really fix anything as the floppy disc is destroyed again as soon as you try to write anything to that floppy!
 


LDJ

New Member
#22
The floppy drive issue is also a problem with Virtual PC 2007

It's been a while since I replied to one of the first posts here, but in the meantime I have found that the problems with floppy drives remains, even if the drive is used on VPC 2007 SP1.

VPC 2007 SP1 doesn't have USB drive support, so you have to use a floppy diskette if you want to install an older OS that requires floppies for installation. VPC for windows 7 can't be used, as it has no floppy drive support. :)

For me to see, the only OS'es that can be installed with VPC under Windows 7 are OS'es that can be installed from a booted CD/DVD.

That leaves Windows 3.1 out, unless a cumbersome workaround is used. OS/2 is completely no go, as it requires install diskettes.
I have the VPC Machines that I care to have, made when I had Windows XP x64 and Vista installed.

I have preserved my full OS/2 system that I had running for almost 10 years, as a VPC Machine, with full setup of Fidonet, mailer tosser scanner nodelist compiler etc. :) and all the postings from Fidonet and OS2-Net that I have kept through the years :) I'll leave it to somebody else to throw the things out, when I'm gone.

As for the need to use "outdated" floppy drives and diskettes, I know that Windows XP x64 can't be installed without a floppy drive for adding "F6 drivers" as the additional drivers are needed for the installation.

I haven't tried if the issue is there with VMware Player or VirtualBox, yet.

Kind Regards
LDJ
 


#23
Possible solution

Hi, new to the forum

Have had the same problem on my recently self built system.
Motherboard is a (giga-byte ga-ma790xt-ud4p).
I have searched Hghi and low for a fix for this item when I came across this article and although the issues at the bottom of the page refers to Linux. I tried disabling HPET in the bios of my board.

I was able to carry out a full format of floppies and write files to them. Once a full format had been carried out on the disks then quick formats also worked.
The disk have been used to boot up my machine which I couldn't do before

Hope this helps someone

regards

Peter
 


#24
HPET? - no such thing here in my sysbios (MA770T-UD3P)
 


#25
Agent Data,

According to the manual for your board HPET is in the power management system part of BIOS. It also says only supported by vista but that was before Windows 7 came out I believe.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#26
Agent Data,
are you running with the latest system Bios? If not I'd check for updates and flash accordingly.
 


#27
Hi all,

Yes, I run latest F5 and found HPET but have not tried it yet - thanks for investigating my issue, appreciated! :)
However, booting into Vista on that very same machine and the floppy works perfectly fine. Consequentially me thinks MS should fix the issue and not require people to fiddle in the bios to make a floppy drive work.

anyway, thank you for all feedback here!
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#28
Thanks for updating but please let us know how you get on with the HPET.. :)
 


#29
Sorry for the long time, I did not forget, but finally I managed to test it and can confirm that disabling HPET indeed works. The floppy now can write properly - I created a boot floppy and it booted successfully.

Begs the question - what needs HPET? does 7 needs HPET?
 


#31
okay, means HPET needs to be on for better performance but renders the floppy useless - I am touched :rolleyes:
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#32
Strange as I have it enabled in my Bios but have no such problems with my floppy drive..
Have you changed any other settings in the bios or is it still running more or less as default?
 


#33
this problem affects only certain AMD chipsets like my 770 - not everyone is affected but quite a number of AMD and Intel people have this problem. Just google it
 


#34
Thanks guys. I too was baffled why something as simple as a floppy disk wouldn't run on Windows 7. I thought it was the disk drive so I spent a tenner on finding that the new one did exactly the same. Having read this thread, I've disabled HPET on my Gigabyte GA-790XTA-UD4 and hey presto, the floppy drive works. The Gigabyte manual says that HPET is to support Vista, even though that motherboard supports W7. Looks like I've been cursed by the legacy of Vista even though I've never used it..Just hope I don't spot any drop in performance with HPET disabled.

Anyway, thanks for the advice and solution!!
 


#35
the media player needs HPET to operate smoothly (playback video/audio) - not a great idea to disable it!
 


#36
Thanks for that info. Guess nothing comes for free and as HPET seems to be put there by manufacturers to help Microsoft its a bit of a tall order to expect them to come up with a fix for it. Anyway I've tried music and video and it seems OK, but that doesn't mean it couldn't be better]
However what I will do is re-enable HPET and then when I know I'm going to write to a floppy disk, I'll disable it in the BIOS for that session only. I only use floppies about once every 4 months for backing up some data in small files. I know I could use CDs or a memory stick, but I kinda like dragging out an ancient floppy disk and firing it up.

I only built this PC a couple of months ago- if I'd have known then what a pain this issue was I might have omitted a floppy drive altogether-
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.