Windows 8.1 no Sleep in Power Options

RodBarnes

Honorable Member
I have a Windows 8.1 system which does not display the "Put the computer to sleep" option. My goal is to set this system to never sleep so it continues to run when unattended.

This is one of four Win8.1 VMs, three of which display normal Power Option settings, while this one does not. On this last one, if I go open Power Options and click on the "Change plan settings" beside any plan, the option "Put the computer to sleep" does not appear -- at all. It is not there. Only the "Turn off the display" option appears.

Upon further investigation, I found that going to "Change advanced power settings" also does not show the "Sleep after" setting under "Sleep". It only lists the "Allow wake timers" setting.

I know I can use "powercfg -h [on|off] to either show/hide the "Hibernate after" setting under "Sleep". (NOTE: On my VMs, I normally have this option disabled so this setting does not normally appear.) But I can't find any way to show/hide the "Sleep after" setting so I can't figure out what to do to cause it to appear.

Bottom line, I want to set this VM (as with all of them) so the "Put the computer to sleep" option is set to never.
 

BIGBEARJEDI

Fantastic Member
Premium Supporter
Make/Model of your computer would be helpful. Full hardware specs would be more helpful. How much RAM does this computer have? On my 4GB computers with W7/W10, I can't even run 1 VM session, let alone 4.:scratch: Perhaps you have exceeded your available RAM usage?:andwhat:

If you have a spare HDD lying around remove the drive with the 4 VMs, install W8.1 on the spare drive and attempt to load just 1 VM session and see if you can get the no-sleep option if your VM. If so, it could be a low-memory or memory-leak problem with the original HDD with the 4VMs.:andwhat:

Thanks, :lightbulb:
<<<BIGBEARJEDI>>>
 

RodBarnes

Honorable Member
These are all VMs sitting on a VMware host (non-Windows). This isn't a matter of resources on the host. It is only this one VM that is exhibiting the issue. I have read many other articles which seem to circle around this article but none were helpful for my specific case of not being able to view the "Sleep after" option.
 

BIGBEARJEDI

Fantastic Member
Premium Supporter
Still, if it's a non-windows machine, Linux, Mac, or Solaris or something, you could still try my drive swap out test. Perhaps I'm confused,:scratch: so you are using a Windows8 machine as a client to login over the Internet? If you're logging into a VM-host that's running multiple VM sessions, one of those could be corrupted on the server side. We have some other folks here that might be willing to chime in (neemobeer and Norway) if you can provide us a better idea of your configuration and usage. They are really more knowledgeable than me on VMs, though I've used them for 20 years on and off.

Thanks,
<<<BBJ>>>
 

RodBarnes

Honorable Member
These are test VMs for evaluating releases upon various Windows clients -- Win7, Win8.1, Win10, x86 and x64 of each, Pro and Enterprise of each. 12 VMs in all. None of them have this issue except for this one Win8.1 VM.

I really think the usage and resource topic is a red herring. It is only the one VM that has this issue and I've read enough articles of others experiencing similar weirdness with the power options that there has to be some power option related configuration that is whacked.
 

Neemobeer

Windows Forum Team
Staff member
Which hypervisor are you using? ESX(i), virtualbox, hyper-v?


Also post your current power plan on the guest. From an elevated command prompt type powercfg /query
 

RodBarnes

Honorable Member
Well, strange... I've continued to dig into this trying to see what was going on. I just finished some Windows updates on this VM and rebooted. And now it is showing the "Sleep after" setting. Previously, even after a reboot, the setting was not there. I guess something in the updates jogged it loose.

Thanks to all for the input.
 

Neemobeer

Windows Forum Team
Staff member
You can actually change which settings are visible in "Advanced Power Settings" via the registry. I'm not currently on a Win box, but I believe it's in HKLM\System\Control\CurrentControlSet\Power. Everything is represented as a GUID so if it happens in the future you can look up a setting guid on the msdn site.
 

RodBarnes

Honorable Member
I found the page Power Setting GUIDs (Windows) but it lists only the "most useful to applications" -- none of which affect the sleep setting. These are more for apps to register for power change notifications.

From research, it appears the primary means to interact with these (other than via Power Options GUI) is through the powercfg command.

I did find that these are also configurable in the global policies (gpedit.msc) so that will also be something to remember.
 
Top