Windows Update error code 800b100

#1
I'm running Windows 7 64 bit on a dell laptop ( which is wireless) About 95% of my automatic updates fail with the code "800B0100" tried the "fix it" from MS, no luck. I try to download the "system rediness update tool" from MS but keep getting a page not found prompt. I turned off the windows and McAfee wirewall, but that didn't help either. I'm using a Netgear N600 router. Maybe it has a firewall. It's just a Windows problem though, all other updates ( McAfee, Adobe, etc.) work ok. I'm really stumped.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
Are you running an Anti-virus? I have seen some of those cause problems for Windows update.

The error (800b0100) seems to mean "No signature was present in the subject"

If you want, copy the WindowsUPdate.log from the C:\Windows folder to your desktop. Copy the last 4 days of entries and paste them to a text file and zip, then attach using the paperclip on the advanced replies. I will attempt to check it to see if I notice anything.
 


#3
Thanks. I am running mcAfee, but tried turning off the firewall to no avail. The problem started in Dec. prior to that time updates were 100% successful. I uninstalled the last successful update ( something to do with ActiveX kill bits) thinking it may have caused it but the problem persist. I was finally able to download the system tool and will install and run it this evening and see how it works. Thanks
 


#5
I plan to soon as my subscription runs out. Updates had been running smooth until a couple of months age. Right after the activeX update ( KB2618451) the problem started.
 


#6
Remove that Update. Go to Update History & Delete it. Then see how things are.
 


#7
did that, no help. I'm going to run the MS system update tool and see if that helps.
 


#8
nothing there. the activeX updates go through, but nothing else. I'm stumped. Might be mcafee after all.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#9
If you want to copy the WindowsUpdate.log in the C:\windows directory to your desktop, then zip it and attach using the paperclip, I will try to check it.

Have you changed your internet connection lately? Have you shut your system completely down, then rebooted?

If it doesn't work itself out, one thing you might end up doing is deleting the SoftwareDistribution folder in the C:\Windows folder. It will take a few days for it to recover, but it usually clears things out. Also, using Windows Update and telling it to check for updates might help.
 


#10
Take McAfee out, put MSE I & try...even, if just as an experiment

You've tried lots else, already. Did you do netsh winsock reset, too? I forget.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#12
The file you are providing is not the one I was asking for. But it says the same thing, that the updates cannot be verified as to a signature.

Did you ever get the Update readiness tool to run, and if so, where is the log from it? I think it is called Chksur.log and located in the same folder as the CBS.logs.
 


#13
is this it?
 


Attachments

Saltgrass

Excellent Member
Microsoft Community Contributor
#14
That file shows part of the problem, you have many corrupted backup files and catalogs that have been corrupted or not verifiable. Why this is occurring needs to be addressed and then the entire database needs to be rebuilt.

You are running an anti-virus that might be involved. When I was running one, I would see things like extended update install times, especially during reboots, and many failed install attempts. There might be a setting to stop it from interfering, if it is, but you need to see if you can find that. If you want to keep what you have, then keep an eye on the updates to see if they become corrupted again if a repair can be accomplished.

If you have run any registry cleaners, you might stop that for testing, or anything else that says it is cleaning your system. You might try running a System File Check for an administrative command prompt by typing sfc /scannow. You also might try running a Chkdsk to see if any corruption is occurring on your hard drive. This might also repair some current problems.

But for now, I am going to recommend you either rename or delete the C:\Windows\SoftwareDisbribution folder. That will force the system to rebuild the database. It will take maybe a couple of days, depending how often the updates are attempted.

While this is going on, you probably need to hide the SP1 update if it is offered. There are some instances where, if other updates were installed in conjunction, would cause problems.
 


#15
tried to delete "software" folder but get a "can't delete because it's running somewhere else" prompt. I turned off update and Mcafee wirewall. What did I miss?
 


#16
Have to make a new folder, softwaredistribution.old (1st) then, reboot, then, delete the other (1).
 


#17
That worked. I've deleted the folder, rebooted and turned windows update back on. I'll give it a couple of days and see if that fixed it. Thanks for your help.
 


#18
You're welcome... my pleasure :thumbs_up:

Drew
 


#19
Didn't work. Question is now, how long can I function without updates. Are they even necessary? Probably can't use Windows Essentials without them. Maybe the problem will go away when mcafee goes.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.