0x8030002F Error trying to upgrade for repair

Discussion in 'Windows 7 Installation' started by DarkS7ar, Feb 7, 2012.

  1. DarkS7ar

    DarkS7ar New Member

    Joined:
    Feb 7, 2012
    Messages:
    8
    Likes Received:
    0
    Alright so, my issue is two-fold.
    I cannot install SP1, I keep getting error code 80073712 error. I've done the update readiness tool successfully, sfcscan with unrepairable errors, manual SP1 install. Nothing has worked, so I'm trying to do a inplace upgrade to hopefully replace missing/corrupted files but I get the 0x8030002F error when I start the Win7 disk.
    Booting from the disk results in it telling me that to do an upgrade I have to boot from Windows.

    I'm pretty much at my wits end and incredibly frustrated. I have installed Windows 7 on my laptop with no issues at all so I don't think it's a disk problem.
    Any thoughts, suggestions, or requests for more information?
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    How long has the system been up and when was the last time you ran a System File check?

    If you ran the Readiness tool, did the log (CheckSur.log) mention any problems?

    If the SFC found corrupted files, there is not way to know how many until you check the CBS.log. But it usually says both the original file and its backup are corrupt. If you have one or two you might be able to replace them, but something is causing the corruption.

    The 80073712 error means "The component store has been corrupted"

    Why the DVD will not start for a repair install, not sure, but it might be related to the bad system files. Where did you get the install DVD?
     
  3. DarkS7ar

    DarkS7ar New Member

    Joined:
    Feb 7, 2012
    Messages:
    8
    Likes Received:
    0
    Been up as in how long has Windows been installed? A few months.

    from the checksur.log
    Found 10 errors
    CSI Manifest All Zeros Total count: 10
    Unavailable repair files:
    winsxs\manifests\amd64_microsoft-windows-m..cursor-library-ansi_31bf3856ad364e35_6.1.7601.21747_none_acdc7a2fd087986e.manifest
    winsxs\manifests\x86_microsoft-windows-m..simple-provider-dll_31bf3856ad364e35_6.1.7601.17632_none_c180eb382346c80f.manifest
    winsxs\manifests\amd64_microsoft-windows-m..simple-provider-dll_31bf3856ad364e35_6.1.7601.17632_none_1d9f86bbdba43945.manifest
    winsxs\manifests\amd64_microsoft-windows-m..drivermanager-trace_31bf3856ad364e35_6.1.7601.21747_none_de05c1b3714cccd3.manifest
    winsxs\manifests\amd64_microsoft-windows-m..sor-library-unicode_31bf3856ad364e35_6.1.7601.21747_none_cf64bd82be6eec44.manifest
    winsxs\manifests\amd64_microsoft-windows-m..drivermanager-trace_31bf3856ad364e35_6.1.7601.17632_none_dd81f362582b9265.manifest
    winsxs\manifests\amd64_microsoft-windows-m..cursor-library-ansi_31bf3856ad364e35_6.1.7601.17632_none_ac58abdeb7665e00.manifest
    winsxs\manifests\x86_microsoft-windows-m..simple-provider-dll_31bf3856ad364e35_6.1.7601.21747_none_c204b9893c68027d.manifest
    winsxs\manifests\amd64_microsoft-windows-m..simple-provider-dll_31bf3856ad364e35_6.1.7601.21747_none_1e23550cf4c573b3.manifest
    winsxs\manifests\amd64_microsoft-windows-m..sor-library-unicode_31bf3856ad364e35_6.1.7601.17632_none_cee0ef31a54db1d6.manifest

    I have run SFC at least 20 times throughout this issue, the last time being about half an hour before posting. Attached is the log.
     

    Attached Files:

  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Your log only covers last night around 9 p.m. and then midnight to 1 a.m. with no SFC runs indicated. The CBS log archives itself so your information is probably in the last .cab file.

    When you tried to install SP1, what happened exactly? Did it roll back from the attempted install? Since it seems many of the files mentioned are SP1, it appears your system is in an intermediate state. Check Windows Update and see if it mentions anything about the SP1 update and you might be able to uninstall it from there if it does.

    You might start your system in Safe Mode to see if anything happens. I had one system that would not boot normally, but when started in Safe Mode it started a rollback of SP1. I f the system has been up for a few months, I wonder why SP1 wasn't done much earlier.

    Depending on what type of Windows 7 Install DVD you have, you can download a full Windows 7 .iso with the SP1 built in. You may want to try that. If you burned the DVD yourself, you might want to try again, and even re-download the .iso.

    Bad Link
     
    #4 Saltgrass, Feb 8, 2012
    Last edited: Feb 8, 2012
  5. DarkS7ar

    DarkS7ar New Member

    Joined:
    Feb 7, 2012
    Messages:
    8
    Likes Received:
    0
    I'm using a OEM copy of Win7 Ultimate that came with another laptop.
    When I install SP1 through Windows Update it fails in the 70-75% range and gives me the 80073712 error
    When I install using the downloaded SP1 it takes an extremely long time, to the point I thought it had locked up, before telling me it can't install.
    I've tried normal mode, safe mode, I've tried normal mode with selective boot, I've tried safe mode with selective boot. I've covered every single suggestion on every single thread I can find on Google, and the only one I haven't been able to try is the inplace upgrade, which is why I created this thread.

    On the link you gave me, the .iso for my version is a dead link.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Sorry about the link, but the site mentions the links are time limited and may change. The Amazon link was not there the last time I checked, but you may be able to get a good link in the future.

    Some OEM media are for use with a particular computer. It seems every manufacturer does it differently, so hard to say if the errors are related to that or something else.

    Looks like you might try to go the flash drive route, if you ever get a good ISO or the Windows files to use.

    Maybe this link:

    http://www.mydigitallife.info/official-windows-7-sp1-iso-from-digital-river/
     
    #6 Saltgrass, Feb 8, 2012
    Last edited: Feb 8, 2012
  7. DarkS7ar

    DarkS7ar New Member

    Joined:
    Feb 7, 2012
    Messages:
    8
    Likes Received:
    0
    Not your fault, I was just letting you know.
    The OEM version should work, I have it running on another laptop and it installed SP1 just fine. The original laptop it came with is now a Linux box.

    That link worked, downloaded and mounted, but I can't do a inplace upgrade because I have to already have SP1 installed to upgrade to a version with SP1.
    Incredibly frustrating.
     

Share This Page

Loading...