Windows 10 Absolutely no internet

Discussion in 'Windows 10 Help and Support' started by theAdmin, Sep 11, 2016.

  1. theAdmin

    theAdmin New Member

    Joined:
    Sep 11, 2016
    Messages:
    2
    Likes Received:
    0
    Hello everyone, and welcome to my first post. I am posting here because I have had this issue for about a month now, with no fix found.

    I am running Windows 10 Pro 10.0.10586, which came with the computer (about 1-2 months ago), and since I have no wired ethernet available where it is, I had the internet running through a (Raspberry pi use intended) usb wifi dongle. It worked, but had the common "Wifi connected but no internet" issue that has bothered many W10 users for a long time. I tried to fix that, but on a reboot, ALL my network adapters were gone (except a mysterious "Ethernet 2" which seems to have no physical port?!), so i got stuck with a "not connected - no connections are available" in the taskbar.

    So, after much searching, I went to my local "computer repair and resell" shop, and the guy there advised me to get a "Tenda Usb Wireless" dongle for ~$30 (as the person who walked in before me got the last pci one!!), and since it came with a mini-cd in the packaging,I thought "Well, if it includes drivers, it should install an adapter, right?"

    WRONG!!

    Apparently, it is incompatable with windows 10 (a fact I only found out after scanning through the pdf user manual) and now I still have the problem, so I have finally turned to the "forum post route".

    BTW, I don't want to reset as I don't want to lose some software that the computer came with (Vmware Pro) as I don't want to have to buy it.

    Any ideas?
    Thanks,
    theAdmin

    EDIT: I am posting from my alt pc, don't be fooled by the thing on the left that says linux!
     
  2. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,019
    Likes Received:
    125
    Try using the Media Creation Tool to make yourself a bootable USB stick with the latest version of Windows 10 Anniversary and do an upgrade install, see if it fixes your network adapter issue..
     
  3. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,412
    Likes Received:
    366
    Are you using the pi setup as an access point? If so, why can't you just buy a cheap switch and plug the Win 10 into the switch? If you get the message Connected, but no internet then there is probably an issue on the pi such as DNS, DHCP or gateway not properly configured.
     
  4. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,798
    Likes Received:
    219
    Hi,
    It would be nice if we knew the Make/Model of the computer you have. Also, is it a desktop PC or a laptop/tablet? If a self-built PC or custom-built PC, please post Make/Model of your Motherboard, CPU chip, GPU card, PSU Make/Model/Wattage.

    In any case, sounds like you are using very cheap wireless adapters IMO. You should buy a quality usb adapter such as Cisco/Linksys or Netgear. All other brands have various degrees of poorly written drivers, and most of those likely as not crash any normally working W10 into a burning ball of flame!!:waah: You're only talking $10-$20 more for a quality adapter, why not buy something that's guaranteed to work? I'm sure you've hear the old saying "You get what you pay for!".

    Best of luck,:encouragement:
    <<<BIGBEARJEDI>>>
     
  5. theAdmin

    theAdmin New Member

    Joined:
    Sep 11, 2016
    Messages:
    2
    Likes Received:
    0
    I SOLVED IT!!!!

    Today I found my old super-long network cable and ran it through the house from the router to the computer.... nothing. Then, I right-clicked on the mysterious "Ethernet 2" and clicked (randomly...) Add to bridge... and... BOOM! It reinstalled ALL my network adapters. Now, i think that i'll see about connecting a mac with ethernet sharing on... i'll see!

    Anyway, thanks all for the info! (I only just saw some of it, but still!)

    I'll see u all in the interwebs!
     
  6. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,798
    Likes Received:
    219
    I've seen this solution before. It works on some computers, not all, it depends on whether the NIC driver can run bridging between 2 Ethernet connections on the same computer.
    Anyway, Glad you got it fixed!:up:

    BBJ
     

Share This Page

Loading...