Adobe Reader 9 browser plug-in doesn't work

Discussion in 'Windows 7 Software' started by GomJabbar, Jan 25, 2009.

  1. johndubya

    johndubya New Member

    Joined:
    Jan 27, 2010
    Messages:
    6
    Likes Received:
    0
    It's 2010, and I'm still getting the same blank error screen when trying to open a PDF document in a browser window with Windows 7 and any browser (IE8, Firefox, etc.). Here is what the box looks like:

    blank_error.

    To help describe my situation, I am creating PDF documents on the fly through PHP. I've been doing this for years without a problem until today, when I freshly installed Windows 7 on this computer. Now, the above blank error message pops up completely at random. Sometimes, the PDF opens fine; sometimes it shows the blank error box and doesn't show anything. I have tried opening the same PDF document every time as a constant, and it does work sometimes, so I know the PDF does work some of the time.

    I tried reinstalling Adobe Reader 9.3 - no luck.
    I tried uninstalling Adobe.com and Adobe AIR - no luck.
    I tried clearing the browser cache - no luck.
    I tried changing some of the headers through PHP - no luck.

    Are we just SOL with this problem? I can't believe Adobe or MS hasn't fixed this yet. This is incredibly annoying.
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,788
    Likes Received:
    1,563
    That does sound rather annoying... I had a quick look through Adobes site to see if anything looked remotely like a solution but I didn't see one. I did find however the link for the 'Adobe Reader support forum' which may be of more help?

    Adobe Forums: Forum: Adobe Reader
     
  3. johndubya

    johndubya New Member

    Joined:
    Jan 27, 2010
    Messages:
    6
    Likes Received:
    0
    Thanks so much for the link, kemical. I'll try over there as well. It's funny...when I click on the "View PDF" link that they provide for each discussion, the PDF opens in the browser just fine every time (I tried 10 times in a row). I'm wondering if this problem is coming from the header() being defined incorrectly through PHP or something like that...
     
  4. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
  5. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,788
    Likes Received:
    1,563
    Great idea Jim.. I forgot to mention foxit.
     
  6. johndubya

    johndubya New Member

    Joined:
    Jan 27, 2010
    Messages:
    6
    Likes Received:
    0
    Using a program like Foxit might benefit me personally, but if there is a way to fix Adobe Reader (which 99% of my users are using) or a way to fix the way I am building PDF documents, I would much prefer that. I've posted at Adobe's forums, so maybe a developer or someone can figure out why Adobe Reader is being so stupid. Thanks for the suggestions, guys.
     
  7. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,788
    Likes Received:
    1,563
    No worries John, let's hope your post brings forth results..
     
  8. wonderwhite

    wonderwhite New Member

    Joined:
    Jul 15, 2010
    Messages:
    2
    Likes Received:
    0
    Have a solution to anyone still getting these problems using firefox:

    Tools > Options > Application Tab > Where you see all the adobe content types change action to 'use adobe reader 9.1'.

    Helped me as I was presenting using 'use adobe acrobat'.

    Hope it helps someone as I made an a/c just to post this :p
     

Share This Page

Loading...