ASUS 144Hz Monitor issue

Romchik9007

New Member
Hello all, hope all is well.
I've bought a brand new monitor: ASUS VG248QE
But here's the problem, when the monitor arrived, it came with a CD of what I assume would be drivers for the monitor. However, my PC doesn't have a generic CD/DVD reader. I've installed and connected the monitor to the PC, and all is working. However, in my 'Setting>Display' section, Windows detects it as a "Generic PnP Monitor".
That's not supposed to happen, right? It should detect the monitor as it is.
I've tried to look for the ASUS WHQL Driver for Windows 10, but no luck.
Can someone please lead me to the right direction here?
It'd be much appreciated.
Thanks.
 

Neemobeer

Windows Forum Team
Staff member
That's common and the monitor driver isn't usually required unless there is some specific feature that needs it.
 

Romchik9007

New Member
Here you'll find your driver:
VG248QE Driver & Tools | Monitors | ASUS USA
Just choose your operating system.

Sent from my SM-N950F using Tapatalk
Already ahead of you there. I've picked Windows 10, and the driver downloads successfully. It installs a software called ASUS MultiFrame. But whenever I try to launch it from my desktop, it just doesn't want to.
And also, this may sound weird, but every time I change my refresh rate to 144Hz, for some reason my internet just breakes. Like, whenever I search something on Chrome, it says there's no Internet connection.
 

GDany

Well-Known Member
Are you sure you picked the right version of windows (32 bit or 64 bit)?
Are you sure your display adapter card supports the 144 screen refresh rate?

Sent from my SM-N950F using Tapatalk
 

Romchik9007

New Member
Are you sure you picked the right version of windows (32 bit or 64 bit)?
Are you sure your display adapter card supports the 144 screen refresh rate?

Sent from my SM-N950F using Tapatalk
Absolutely sure I've picked the right Windows.
In terms of display adaptors, that's the DVI cable, right?
If so, I am using the DVI cable
 

GDany

Well-Known Member
No, I'm talking about the graphics CARD which is installed in your computer. The DVI port you are connecting the cable to it is the outlet port of the graphics card. Check your computer specifications and find out what type of graphics card you have installed and then look for its specifications (it should be an Nvidia or AMD usually).

Sent from my SM-N950F using Tapatalk
 

nmsuk

Windows Forum Admin
Staff member
Premium Supporter
Absolutely sure I've picked the right Windows.
In terms of display adaptors, that's the DVI cable, right?
If so, I am using the DVI cable
You need to be using display port or hdmi. DVI lacks the bandwidth for 144hz
 

Romchik9007

New Member
No, I'm talking about the graphics CARD which is installed in your computer. The DVI port you are connecting the cable to it is the outlet port of the graphics card. Check your computer specifications and find out what type of graphics card you have installed and then look for its specifications (it should be an Nvidia or AMD usually).

Sent from my SM-N950F using Tapatalk
Ah right okay I got ya. I've got a GTX 1070 Zotac AMP Edition. And I'm fairly certain that should be able to handle 144Hz 1080p?
 

GDany

Well-Known Member
From Asus site:

"To activate 144Hz function (in 2D mode), both DisplayPort (or Dual-link DVI) and a selected graphics card with the latest driver are required. Please kindly contact the service center of your graphics cards companies for further technical supports."
 

kemical

Windows Forum Admin
Staff member
Premium Supporter
If the driver supplied doesn't have a exe then you have to install it via Device manager.

Find device manager and the pnp monitor. Click update driver followed by browse my computer, find the folder which contains the driver 'inf' and click on that followed by ok.
Your monitor should now say the proper name when viewed in device manager.

(I only had to do this myself two days ago so know it works.
 

Romchik9007

New Member
From Asus site:

"To activate 144Hz function (in 2D mode), both DisplayPort (or Dual-link DVI) and a selected graphics card with the latest driver are required. Please kindly contact the service center of your graphics cards companies for further technical supports."
Alright, so the best option would be is to contact Zotac themselves?
 

Romchik9007

New Member
If the driver supplied doesn't have a exe then you have to install it via Device manager.

Find device manager and the pnp monitor. Click update driver followed by browse my computer, find the folder which contains the driver 'inf' and click on that followed by ok.
Your monitor should now say the proper name when viewed in device manager.

(I only had to do this myself two days ago so know it works.
Alright pal, I'll look into it. Cheers
 

GDany

Well-Known Member
Alright, so the best option would be is to contact Zotac themselves?
No, you don't need to, your graphics card is ok, it supports the 144 refresh rate. You just only have to use the right cable, as nmsuk said. I expect that after using the right cable you will be able to also start the Multiframe.

Sent from my SM-N950F using Tapatalk
 

GDany

Well-Known Member
This is from the user manual......The 144hz refresh rate is supported only for 2D mode, 100Hz and 120Hz for both 2D and 3D modes.
But this is possible only when using the supplied DVI (dual-link) cable or a DisplayPort cable in conjunction with Nvidia 3D Vision kit for 3D mode.
Capture.JPG
 
Top