Can't boot on selected drive

Scarecrow

New Member
Hi,

I recently built a PC with 2 drives, a SSD and a HDD. I had originally installed Windows on the SSD but after a malfunction, I temporarily installed it on the HDD while the SSD was getting replaced.
When the new SSD arrived, I did the following :
- Unplugged the SATA cable from my HDD
- Installed the SSD in the computer
- Installed Windows on the SSD via usb

On the first boot after installation, it booted on the SSD since the HDD was not plugged in. Then I shut it down, plugged back the HDD SATA cable and booted into bios to set boot options.

First weird thing : my HDD was not appearing in the list of boot options. Only my SSD and my SSD followed by (Windows boot manager) appeared in the list.

I chose the regular SSD entry and booted, but it booted on the HDD. So I tried again with the Windows boot manager option and it boots on the SSD but a third drive appears in my windows explorer that's separate from the rest of the SSD, so I'm not sure what's happening.

Basically, it's booting on the only drive I can't select, and I'm afraid to wipe the HDD while in Windows boot manager because I don't really know what it actually is.

Sorry if the thread seems dumb, I'm not that great with computers.

Thanks
 

Neemobeer

Windows Forum Team
Staff member
I would start by verifying consistency between your firmware's boot method (UEFI vs Legacy) and what partition scheme each drive has (GPT vs MBR) if you have a mismatch then one of the disks may not show as bootable
 

Neemobeer

Windows Forum Team
Staff member
Boot into your firmware and verify if your boot mode is set to legacy (somethings called CSM) or UEFI. Then boot into Windows and look in disk management to make sure your two disks are the same type.

There should be an EFI boot partition for UEFI booting and MBR (System partition) if it's configured to boot legacy/csm
 

Scarecrow

New Member
In my bios, I have two different options associated with legacy and UEFI.

STORAGE BOOT OPTION CONTROL is set to legacy
OTHER PCI DEVICE ROM PRIORITY is set to UEFI
I tried to change the bios settings to both legacy or both UEFI and it still boots on the HDD instead of the SSD

This is what my disk management window looks like :
My SSD has an EFI partition but my HDD doesn't have either EFI or MBR written anywhere.

I don't really know what to make of it.

I really appreciate your help.
 

Neemobeer

Windows Forum Team
Staff member
The top disk has (System Reserved) that is basically MBR. Basically your SSD won't boot because of the Storage Boot: Legacy.
 

Neemobeer

Windows Forum Team
Staff member
You'd either need to reinstall Windows on the SSD as legacy (you probably need the PCI boot prioirty set to legacy then reinstall), or Set them both to UEFI and then re-install on the HDD.

UEFI with secure boot is going to be a bit more secure and UEFI is much smarter when it comes to booting, partitions allowed and size of disk allowed (greater than 2TB not super important in your case since your disks are not that large).
 

Scarecrow

New Member
What if I wipe the HDD ? Would that allow me to boot from the SSD and then set the HDD as UEFI to avoid further boot conflict ? I don't mind losing the data on it since I had planned to only use it temporarily and I'll just have to download my games.
Edit : and how can I wipe the HDD on which the system is running without having access to another drive on the same computer ?
 

Scarecrow

New Member
I tried that and it still boots to the HDD.
I tried removing the HDD from all lists that had "boot" in the name and the PC booted to a message telling me to select a proper boot storage.
I just tried disabling CMS support and it looked like it booted on the SSD (because the login screen and wallpaper are default and it asks me to update windows) but it has actually booted from the HDD and the system partition from the HDD appears as an additional drive in the explorer as "System reserved (D: )".
I have no idea what's going on.
 

Scarecrow

New Member
I just tried booting with the HDD unplugged and it boots just fine on the SSD. So the SSD works but the HDD system partition somehow finds a way to override the SSD despite CMS being disabled and it prevents to boot from SSD when I leave it plugged but remove it from all boot lists.

So I guess I'm just gonna wipe it. Can I format it directly from disk manager while the OS I'm using is installed on it or would that be dangerous for the drive/machine ? Is there a way to wipe a drive from bios or something like that ?
 
Top