Can't turn on the Windows Firewall?

#21
Mike, read this:

You're using the wrong settings...

Configure How a Service Is Started

I have to be out for the evening.

Cheers,
Drew
201672.jpg
 


Last edited by a moderator:

davehc

Essential Member
Premium Supporter
#22
I don't think the net framework had much to do with your problem, Mike. Did you try the GPEdit suggestion before you went into the services?.

Anyway, Open, in services, the Log On tab again. Untick "Local System Account" , and click on"This Account". This should now come up with a row of asterixes in both Password and Confirm password. If not, put in your OS password in both instances. Then try and restart the Firewall.
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#23
Hi Guys

Yes I did do the GPedit, and the command prompt entry too.

I can establish that it is Local Service.

If I hit browse and type in Local Service and hit check names it puts the underline beneath it.

Firewall 07.JPG

Then if I return to the previous page it shows in the correct place.

Firewall 08.JPG

But when I hit OK I get this....

Firewall 09.JPG

I have no idea what the password could be, I never set any passwords on this computer.

So I don't know where to go from here.

I don't want to run Refresh, the computer is running great except for this one thing.

I did verify that Lord of the Rings Online doesn't run now that I've removed Net Framework 1.1.
I've had any account ever since beta, but I really never get into the game and play anymore.

I just log in and pay the rent on my house so that I don't lose it.
Maybe it's time to give up on that.

I have a install disk for Windows XP 64 bit that's never been used I could dual boot but I guess that going to far since everything else works in Windows 8.

Anyway I'm off to bed now.

See you tomorrow.

Mike
 


Last edited by a moderator:

davehc

Essential Member
Premium Supporter
#24
In that case, forget my last!

It looks like, somewhere along the line, a password has been set??

I must confess I have lost the thread of your "mods" and , if it were me, I would put my image back on.
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#25
Hi

Well at this point I don't have a backup since I was still in the setting up stage.
My only option is to run Refresh and see if that fixes it or live with it.

In which case I still need to find a stand alone firewall that doesn't replace Windows Defender.

Mike
 


davehc

Essential Member
Premium Supporter
#26
You already have one, Mike, as I said - In your router. It will be configurable and a hardware firewall competes favorably with a software version.
 


#27
Mike, do the Refresh, leaving data intact. (Correctly) It should be set to This Account, Local Service & it should be happy w/ its self-generated P/W.

Cheers,
Drew
201672.jpg
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#28
Hi

Well I have 2 now, the one in my router and Comodo Firewall.

I managed to get it installed and running without any of the other stuff that comes along with it, i.e. Geek Buddy and Dragon, security plus etc.

It seems to be working and now slowing down my computer.

I'll try the refresh thing in a couple of days after I get some things done, I've spent too much time on this and I have things I need to do.

I did read that Refresh will not change Firewall setting in one of the things I found.

But it's worth a shot.

I'll have to disable Comodo before I do it or it will just pick that up as the active firewall.

Mike
 


#29
Do the Restore when you can, Mike. Also, you can ring Microsoft @ that # I gave you. Be good when you get this resolved cus as you see would be better than using 3rd Party items. And, yes, you will have to disable Comodo.

Cheers,
Drew
201672.jpg
 


davehc

Essential Member
Premium Supporter
#30
Did you ever solve the Defender problem, Mike?

I emulated it (big mistake.) fought for half a day and finally solved it - for me anyway!
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#31
Hi Dave

I didn't solve it.

I installed the Comodo firewall and it's working well, so I left well enough alone for now.
I think the Comodo is more powerful then the Windows one but maybe it's just more in your face.

It works fine with Defender running but the Windows 8 Firewall is still non functional.

How did you get it solved, maybe it would work for me?

Mike
 


davehc

Essential Member
Premium Supporter
#32
This is what worked for me. I am not 100% certain which individual tweak it was - or it may have been a combination? A heck of a lot of rebooting required!
My installed Antivirus for the test was Avast. Installed and, surely enough, The Firewall was disabled.
1. Uninstalled AVG - no result.
2. Tried the Gpedit trick - didn't work
3. Tried restarting from the services - didn't work. It started and stopped again.
4. Did a search on the registry and deleted every entry of Avast. Oh my! what a dirty uninstall that had been. - didn't work
5. As a default, on a new installation, I always disable the "Security Centre" service. Re-enabled - didn't work
6. All the above required rebooting. So by then I was a bit short of ideas.
7. Then, I thought, how about basics. Control Panel - Action Centre (All of which features I normally have turned off) - There was a message "Windows Firewall is turned off or not set up correctly. Turn on Now. I did so and the Firewall was active again. Turned off the security centre service again and the Firewall stayed active. Problem solved.
 


Last edited by a moderator:

MikeHawthorne

Essential Member
Microsoft Community Contributor
#33
Hi Dave

I've kind of gone through the same thing, but I never had Defender not working.
Only the Firewall won't start and now because it want's some kind of password I don't have.

I haven't tried setting a password yet, and I don't want to do refresh because it removes all your installed software.
So for now I'll either live with it or try and set a system password.

I never do that but I may have to.

The computer is running great right now, and I don't want to screw things up trying to make one thing work that I can really do without.
I've done that to many times before. LOL

Sometimes you have to leave well enough alone.

At this point do have Net Framework 1.1 installed, so my software is working.

Thanks for the help.

Mike
 


Joe S

Excellent Member
#34
I never liked Windows firewalls anyway. In XP mine constantly turned back on and messed up my network connections. Most likely Windows Update was the cause. I've used Comodo free for a long time and had good luck. It's frustrating to have a problem and fix it and not be sure what you did.
Joe
 


davehc

Essential Member
Premium Supporter
#35
I use my hardware (router) firewall. More efficient and earlier in stopping attack.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.