#1
So I decided that I want to take advantage of the free update, so today I tried to do it.
From windows update I clicked on "Restart now" (Win10 is already downloaded) but it just reboots back to windows 7. After a couple attempts I figured this isn't working. So I remembered that there are some windows enable/disable settings in my BIOS and I went to check it, and yes, windows 8/10 was disabled. I enable that, but, as it warned me, I can't even boot to windows 7 now. I reverted the settings and am back in 7, but can't seem to actually get the update to start properly.

I'm using MSi B150 PC MATE mobo, and i3 skylake processor, I don't think the other hardware is relevant, as I assume it's because of the mobo and the whole BIOS thing.

Ask for extra info, thanks for any help!
 


#3
I don't think the MCT gives you a free update or install of win10
 


#4
That's what the Media Creation Tool is for. Up grade 7.1 and 8.1 to Windows 10!!
Windows 10 is free until July 2016! Did you even read the link I provided??
 


Sonny

Excellent Member
#5
If you use the MCT you can then mount it and run it to upgrade. Once that is done you can then do a clean install.
 


BIGBEARJEDI

Fantastic Member
Premium Supporter
#7
Hi,
I've never heard of a BIOS setting that specifically enables/disables Win8x/10 installation. Would you mind posting a photo of that screen for us?

Thanks,
<<<BIGBEARJEDI>>>
 


William B

Well-Known Member
#8
Leave UEFI enabled and make sure "legacy" is enabled should work. You did not list the GPU you are using, but some newer GPU's, specifically some new R9 370-80-90 GPU's will force the BIOS to act in non legacy and then when you try to upgrade to Windows 10 it won't allow. NV GPU's are more forgiving, all the way up to the GTX 980TI.

So this could be a 2 part issue, one BIOS setting which potentially affects a GPU~Windows 10 install.
 


BIGBEARJEDI

Fantastic Member
Premium Supporter
#9
Adding to what WilliamB said, on some Mobo's with UEFI BIOS, you will actually have to DISABLE UEFI in addition to ENABLING the Legacy setting. In some Mobo's there is actually a 3rd setting in UEFI which makes you set SECURE to DISABLE as well; this prevents the computer from booting from any kind of removable media (DVD, USB, or even FLOPPY). You may have to set all 3 of these to get W10 MCT tool to work. :lightbulb::lightbulb:
<<<BBJ>>>
 


William B

Well-Known Member
#10
That is true (the above). Just this past week I had to disable secure boot, but leave UEFI enabled on a Dell XPS 8700 I was working on for the Windows 10 upgrade from Windows 7. My own system an MSI Z87 and I use a GTX 970. I leave Secure Boot to "Auto", but the OP here could toggle that to "legacy/disabled" if "auto" doesn't work and leave UEFI enabled.
 


RichM

Active Member
#11
In addition to all the good advice above, are you certain your Windows Updates are current and up to date? If they are not you will have issues upgrading even using the MCT to do so.
 


Mike

Windows Forum Admin
Staff member
Premium Supporter
#12
So I decided that I want to take advantage of the free update, so today I tried to do it.
From windows update I clicked on "Restart now" (Win10 is already downloaded) but it just reboots back to windows 7. After a couple attempts I figured this isn't working. So I remembered that there are some windows enable/disable settings in my BIOS and I went to check it, and yes, windows 8/10 was disabled. I enable that, but, as it warned me, I can't even boot to windows 7 now. I reverted the settings and am back in 7, but can't seem to actually get the update to start properly.

I'm using MSi B150 PC MATE mobo, and i3 skylake processor, I don't think the other hardware is relevant, as I assume it's because of the mobo and the whole BIOS thing.

Ask for extra info, thanks for any help!
The Media Creation Tool will let you do the upgrade.

Here is the link from Microsoft: Windows 10
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.