Different type of network printer problem

Discussion in 'Windows 7 Networking' started by sysmai, May 26, 2009.

  1. sysmai

    sysmai New Member

    Joined:
    Mar 1, 2009
    Messages:
    14
    Likes Received:
    0
    Different type of network printer problem (SOLVED!! 0x000003e3 cannot connect)

    I am on a domain. I'll call it system1. It has a print server called sys1-prn. On the domain there are probably around 50 to 60 printers. All HP laserjet 4100 series. They are compatible, and I can connect to all of them except for 1. For some reason I could print to it about a week ago, and then something happened to where every time I try to print to it. It asks me to install drivers. I only have the option to install the drivers from the server or cancel. If I choose to install then it downloads the drivers, and throws me a 0x000003e3 error. Can not connect. In normal cases I would use the local printer work around, but the kicker is that I am using some company written software that has 3 different printers embedded. There is no option to change printers. Just a check mark to choose which one to print to. This is done through a queue. When I press the print button to print to 2 of the printers it has already downloaded the drivers and prints with no problem. When I choose this one printer. It does what I explained above.

    I am going to go with driver error, because I can print to this printer with all the XP computers, and I could even print to it using Win7 a week ago. The main question is; how do I get the network domain printer to use my local drivers for the printers without having admin access to the printer itself? Where does windows 7 store these drivers it downloads. Can I put the locally downloaded drivers in that folder to make the system see those instead of even saying that it needs to download drivers?

    Remember the local printer work around does not work. The company software gives me an error that it cannot find the printer no matter what I name it, because it checks the domain printer against the software, not what you have locally installed. However, if I can get this printer to simply add to my devices, I am sure I can get it to work.

    Thanks for all your help
    _________________________________________________________________________________________________________________________________________________________________
    Solution: Thanks to no one that likes a challenge other than me, I solved the issue. I post this to help any others searching for the same type of issue. This should solve more than just my specific issue as long as it is a ACTIVE DIRECTORY printer issue. Without using the local printer work around.

    - Windows 7 continued to search for a driver automatically for every connection, with no option to choose another local driver. So, if you are having the same type of error, and you know for a fact that you have the correct driver on your computer; then install the driver locally.

    - Go into the registry. You will go to HKEY_CURRENT_USER\Printers\Connections. Under there you should see any printers that you have installed.

    - Create a new key under connections

    - Hopefully you are lucky like me, and were able to connect to any other printers then you can use the entries in those as a guide.

    - if not then you will need to know your print server and printer name on the server.

    Entries for my system

    (String)GuidPrinter REG_SZ {A1FFE77D-4499-4A58-9C67-A036E28ECC12} "see bottom for details on this entry"***
    (DWORD 32BIT)LocalConnection REG_DWORD 0x00000001 (1)
    (String)Provider REG_SZ win32spl.dll
    (String)Server REG_SZ \\"the name of your print server goes here"

    *** - The GuidPrinter entry is the key in all of this. This tells the OS that the driver is already installed and the location to look. When I attempted to put in the path manually it errored out. So I copied the key from an already installed printer. The printers were not exactly the same, so don't worry. It still saw that the driver was installed. It acted almost like it didn't even check for a match.

    - go into your devices and printers and add the printer. Do the same as before with except this time it should say that it installed. DON'T PRINT A TEST PAGE YET.
    - hit FINISH
    - you should see the printer. if you scroll over it you should see needs new driver. Right click it and update driver. Then print test page. Windows may bring up an error, it did for me, however this time it gives the troubleshoot option. It will suggest fixes, like setting as default. LET IT FIX THE ERRORS. Windows 7 will do the rest.

    Your printer should now be operational after long long pain in the ___ time consuming trouble.
     
    #1 sysmai, May 26, 2009
    Last edited: May 31, 2009
  2. tholgate

    tholgate New Member

    Joined:
    May 26, 2009
    Messages:
    2
    Likes Received:
    0
    Same Issue

    I'm having the same issue with my Lexmark x4850 printer. It's WiFi enabled and my laptop, which I installed Windows 7 RC on when it became available, was fine and could print after upgrading but starting giving me errors about a week and a half ago. Now I can't get anything to print. My laptop can still communicate with the printer because it can read ink levels and what not, but I get errors when trying to print and it just ends up canceling the task. I've tried numerous things, and nothing will work to fix it.
     
  3. sysmai

    sysmai New Member

    Joined:
    Mar 1, 2009
    Messages:
    14
    Likes Received:
    0
    An update to my still current problem. First off, I see that people answer the easy questions fast, and a thousand times repeated. Please tell me that there is someone out there that is more knows more about this stuff than me. I get no response to a question that is actually difficult. I have researched everywhere all I see is the same stupid answer of the local printer work around.

    The update is the printer is being ran through a JetDirect 710x print server. So it is the 710x holding all the ip/network settings. The printer is ran into the JetDirect by parallel cable. My biggest mind boggler is that I can print to this printer in XP without even having to install a single driver.
     

Share This Page

Loading...