Display error after W10 Pro x64 new install

email2r2

New Member
Hello,
I've been running W7 on my desktop for the last 10 years and it's been running quite flawlessly. Since W7 won't be supported by Jan 2020 I decided that it was time to upgrade to W10 (clean install with a legit license). It went quite smooth and I've unplug the internet connection while doing it to avoid creating a windows account. So far so good and everything powered up like it should but with the default display resolution. I plug back the internet and saw that it was downloading updates for my different cards...audio + video. It boot again after installing but now the display (now with the appropriate resolution) is semi frozen on the blue window start-up logo. I can see the mouse, can open the start menu but if i try to open an application, all I still see is the blue logo. Funny because if I place the mouse on the small icon in the taskbar (like internet explorer) the icon change color and I can see that internet is running underneath. I'm pretty sure it is the display update but I don't know how to reinstall and be able to choose which update it will install...like with W7 because it will just automatically update sand I still will be stucked. So I cant say I'm impressed with this first attempt. Any suggestion is welcome...Thanks
 

livix07

Well-Known Member
You can Roll Back the driver (change to a previous version) by going to Device Manager > Display adapter, select the name of the adapter and right-click on it and then Properties > Driver.
Have you looked for the latest display driver on the official website of the manufacturer?
 

email2r2

New Member
It's definitely the graphic card driver. I've tried many approach (manually etc) and it's always the same result. The card is an Asus HD6450 and I think it's just too old. The Asus website provide W10x64 drivers but in my case it just doesn't work. I'll buy another graphic card (more recent but nothing expensive) just to see if I can give a second life at my old tower. Otherwise, I'll just keep running W7 which have never gave me any headache for the past 10 years
 
Top