dvd drive not working

Discussion in 'Windows 7 Hardware' started by invisibleninja06, Jan 28, 2009.

  1. invisibleninja06

    invisibleninja06 New Member

    Joined:
    Jan 28, 2009
    Messages:
    10
    Likes Received:
    0
    the laptop im using to test windows is a very common hp pavilion laptop and after installation of windows 7 my dvd drive (tsst corp cd/dvdw ts-l632m ata device) will not function in device manager it shows an exclamation mark and when i try to update drivers it says thier up to date when i check on driver details it shows im using windows 7 beta drivers and i would like to see this issue corrected before the release of the os also i would reinstal the os but i cant without the drive and i don't have an external lying around the exact model of my laptop is a HP Pavilion DV6416ca. Anyone with suggestions just pm me or post plz.
     
  2. Kyle

    Kyle New Member

    Joined:
    Feb 7, 2008
    Messages:
    1,634
    Likes Received:
    53
    Click on Start -> All Programs -> Accessories -> Right click Command Prompt -> Run as administrator.

    Paste the following line and hit enter afterwards

    bcdedit /set loadoptions DDISABLE_INTEGRITY_CHECKS

    Then restart and see if that works.
     
  3. invisibleninja06

    invisibleninja06 New Member

    Joined:
    Jan 28, 2009
    Messages:
    10
    Likes Received:
    0
    tried once so far and nothing still same thing, thx anyways tho i hope i can get it fixed then i'll probably reinstall windows 7 because thats what alot of people are doin.
     
  4. Kyle

    Kyle New Member

    Joined:
    Feb 7, 2008
    Messages:
    1,634
    Likes Received:
    53
    Really I would just go to device manager, right click, and uninstall it, then reboot and see if it fixes itself.
     
  5. BlackWolf

    BlackWolf New Member

    Joined:
    Jan 11, 2009
    Messages:
    286
    Likes Received:
    9
  6. invisibleninja06

    invisibleninja06 New Member

    Joined:
    Jan 28, 2009
    Messages:
    10
    Likes Received:
    0
    ok guys thx i'll try putting in safe mode and disabling then restarting but i've already tried the uninstal and reboot doesnt work out.
     
  7. BlackWolf

    BlackWolf New Member

    Joined:
    Jan 11, 2009
    Messages:
    286
    Likes Received:
    9
    think you undestood me wrong. you don't have to enter safe mode. when you press F8 during boot there will be an option to boot without integrity checks. but just apply the fix I posted above, that should do the trick.
     
  8. invisibleninja06

    invisibleninja06 New Member

    Joined:
    Jan 28, 2009
    Messages:
    10
    Likes Received:
    0
    still not working im afraid is there any way i can use a vista driver instead of the windows 7 driver that doesnt seem to work?
     
  9. BlackWolf

    BlackWolf New Member

    Joined:
    Jan 11, 2009
    Messages:
    286
    Likes Received:
    9
    if deactivating the integrity checks isn't helping I guess your drive isn't compatible with vista/7. you can try to get a vista driver from the manufacturer's homepage and install it, but I guess that won't work.
     
  10. invisibleninja06

    invisibleninja06 New Member

    Joined:
    Jan 28, 2009
    Messages:
    10
    Likes Received:
    0
    ill keep trying but i hope they fix this because alot of people have hp pavilons
     
  11. heloy

    heloy New Member

    Joined:
    Feb 1, 2009
    Messages:
    2
    Likes Received:
    0
    Issues Solved in my notebook

    The problem was the GEARAspWDM.sys installed by my Itunes.
    I had to remove ALL files starting with GEAR0Aspi*.* from the disk. I deleteted them all.
    Then use REGEDIT to also remove all related to GEARAspi.

    You will get a different error (missing driver), the first time you reboot.

    Remove and install the driver again, then in the end you can reinstall Itunes.

    The problem was that the GEARAspiWDM.sys had not UNKNOWN Digital Signer. Not it shows Microsoft Windows Hardware Compatibility.

    if you really want to know if your probles is the same, check the driver and you will see. Also, if you reboot using F8 then selecting the option of not checking Digital Compatibility, you will see that it works, but the next boot the problem is back.

    I hope it helps. It took me many hours reading around until i really find that suggestion.
     
  12. ste win

    ste win New Member

    Joined:
    Nov 12, 2009
    Messages:
    2
    Likes Received:
    0
    windows 7 not working

    hi i have an acer aspire 5800T
    i down loaded windows 7 and now i dont have a d drive or any usb that will work please help :(
     

Share This Page

Loading...