W7 USB mouse and Keyboard driver myteriously stopped working (not installed)

Brando

Senior Member
#1
Dell XPS studio 8100 USB mouse and keyboard not working
replaced HDD and reinstalled windows7 which has fully updated to SP1 and anything else associated. (not factory restore, but from OEM disk(as directed in dell community forum). windows installed and validated without issue been running fine for a week as i updated and reconfigured for my bother in law>

finished this am. shut down the machine and packed it up..took it to brother in laws>

Set up and started, at login screen mouse was working fine until i click on a user account.
Machine freezes have learned machine is not frozen, mouse and keyboard just stop working> hard restart, safe mode, same issue.
After trying a different mouse with same result a brought the machine back to my house and set it back up , same issue. remains
BUT i also had installed teamviewer on it so i am able to access it remotely(without issue) from my machine. Device manager shows under Other Devices
! (yellow exclamation point) Dell USB Entry Keyboard
! (yellow exclamation point) USB mouse Under properties it say driver is is not installed and updating it yields nothing found. Driver search on dell/support...nothing> Photo - Google Photos

a few days ago the support site indicated a BIOS update and chipset driver update which i did, the machine/mouse/keyboard worked fine for days after that. dell support site shows nothing needs to be updated driver wise.

It appears the BIOS is the latest as shown on the dell website, also there is no other version do downgrade the BIOS if that is the issue: Photo - Google Photos If i remove the devices they reappear with the same error after restart.

I cannot understand what is happening here any ideas on how to proceed?
 


Brando

Senior Member
#3
Thanks but from what i can see that issue/fix seems to apply to Windows 10 this is happening on a Windows 7 (Sp1) Machine.
 


nmsuk

Windows Forum Admin
Staff member
Premium Supporter
#4
I posted the wrong link. Please bear with me while I find the one I meant to post.
 


Brando

Senior Member
#5
No worries appreciate the help !
 


Brando

Senior Member
#6
I posted the wrong link. Please bear with me while I find the one I meant to post.
any chance youve come across the correct link ?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top