DVD Drive undetected

#1
I have a Liteon iHaS124 (B version?) and I have kind of a bizarre problem with it. It worked well for over a year, now suddenly I have no detected drive at all.

I tried flashing the FW back to stock, but it says no drive detected. It's definitely connected and powered, I can eject just fine but there is no DVD drive shown under My Computer at all.

I don't see any drivers for this, it seems to be using a default 2006 CD-ROM driver from Microsuck. Dafuq? I thought Windows 7 was newer than 2006 even... If I try to update driver it claims I have the latest driver and there's nothing newer than 2006 -____-

Here's a screenshot from my Device Manager: imgur: the simple image sharer

The yellow exclaimation point is because "windows cannot load the drivers for this device" and the one below it I believe is related to either VMware or another type of Virtual Drive. I disabled it for troubleshooting. If either are uninstalled they just come right back.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top