Error 0x80070017 - Expanding files (0%) - "Cannot install required files"

v1pe

Senior Member
#21
I was having this same issue on a brand new build...

Quad Core i5-750
Geil DDR3 PC3-17000 4GB (2x2GB)
Asus P7P55D Mobo
Radeon HD 4870

After trying a multitude of things to fix it I finally solved it by manually setting my DRAM voltage to the Geil recommended 1.65v (for some reason the auto voltage was set at 1.8v) and my CAS timings to the Geil recommended 9-9-9-28.

I also read on another forum that it's best to do a clean install with only one DIMM in the socket and always flash the CMOS when reformatting once you have everything hooked up.

Just about finished installing Win 7 now...wish me luck..looks like I'm in the clear though.
 


#22
I have this problem too! The most annoying thing is that I've had Windows 7 on my machine before.

[ubuntu] Oops, Windows 7/Ubuntu problem - Ubuntu Forums

I installed Ubuntu, and when I wanted Windows 7 it stopped working. Did anyone come up with a definite way to fix this? I have a laptop and there's never anything connected that needn't be (apart from power cable) during installation.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#23
This thread is several months old, so I would suggest you start a new one and explain more fully. As you can see from the thread, I think there were a couple of new drives installed, and one RAM voltage change. This type of problem is not a lot of folks seem to encounter, so it is probably something with your system, or a bad DVD possibly.
 


#24
I found a thread on a google search, and it said to simply remove some of the memory, and try it again. I removed 2gb of my available 4, and it still failed installation, but I put that one back in and then pulled the other 2gb out and restarted the installation. Voila! It worked.

I installed the 64 bit version of Windows 7 !
This was the store bought copy, fresh out of the package... kept crashing during install saying: "Windows Cannot install required files. The file may be corrupt or missing. Make sure all files required for installation are available and restart the application. Error code: 0x80070570"

Running Linux previously, on a Sony Vaio
Intel Core 2 Duo processor, (before linux it had vista on it...)
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#25
Good info, thanks.
 


#26
Hope this helps, nothing worse than having a problem which you cannot find the solution
 


#27
I had the same problem with the exact same error message 0x80070017 when trying to install my SATA HDD. I then replaced my 3.5 " sata with a 2.5" sata HDD and installed it perfectly. This little laptop drive works like a charm. I then replaced the 2.5" drive with the 3.5 sata HDD and booted to my CD and got the same old error when I tried to install Windows 7.
 


#28
I also have this same problem new out of box oc 64 bit ultra .tried to load on brand new ocz vertex turbo 60 gb ssd hd and its dead . So tried with new 500gb w.d. hd same thing now I have TWO hard drives not working SURE COULD USE SOME EXPERT ADVISE SOON !!!!
 


#29
solved

I had similar issues like the ones before and the only thing I did was burning another disc with lower speed (2x).
I have also to say, that the loading screen after "Windows is loading files ..." took a long long time to enter the language options. And the other steps also took a lot of time but the installation is complete now and everything is working fine.
Installation was with 4gb of ram and an E6750 with Gigabyte P35 DS3.


greetz goeki
from germany
 


#30
posible workaround

windows 7 seems to be much more friendly to motherboard changes from what i experienced so i solved this issue by starting the install on a seperate PC and swapped the HDD to the destination PC after the first reset. This has worked with no current issues...install completed successfully.
 


#31
guys, are you overclocked?

if so reset to all defaults and try again
 


#32
Stalling at 0% fixed !!!

Hey guys i had this same problem when trying to install win7 64 on my PC. I read another forum and one of te suggestions was try it with a different DVD drive aka get another DVD drive and put it in your machine. This worked like a charm for me. Just finishing install now :)

hope this helped

Seb Kade
 


#33
Solution

I have found a solution to this issue!
 


#34
Solution

Sorry about the last post had to do it so i can include links

So i have found a solution that seems to work. I must say it is a huge pain to do but it worked for me. This method was used to install windows server 2008 but should work with windows 7 too.

Background. First note i am installing windows server 2008 x64 however it is the same installation method as windows 7.
I too had my install bar stop at "Expanding Windows Files (0%)" and then got the message "windows cannot copy files required for installation" When doing searches for solutions i managed to come onto this forum. So i tried to burn my ISO (which was downloaded from windows website) with Toast on my Mac (yes i am a mac user for desktop and windows for my servers, don't hate) tried using both imgburn and nero on windows 7. Every time my install failed. I then installed windows 2003 server and tried to do an update using the burned dvd and what do you know!!! It failed too.

What Worked
1-I installed windows server 2003 R2 SP2.(which is what server 2008 can be updated from. I didn't need to activate the server 2003 key because you have 60 days to do so and i only needed it for 1 hour)

2-i download MacicDisc(free download) and installed it on the server 2003
Freeware MagicISO Virtual CD/DVD-ROM(MagicDisc) Overview

3- I took the ISO file(the one that i burned about 20 DVD's with, that never worked)
and mounted it as a virtual drive using MagicDisc

4-Load up the setup and update from the server 2003-server 2008

5-Without any problems at all i had windows server running.

Thats what worked for me. For those wanting to install windows 7(which is everyone)

The idea is the same install windows XP professional x64 or Vista x64 (no need to activate)
Use magicDisc to mount ISO file and upgrade. That should do the trick for everyone, i hope.

If anyone has any questions feel free to email me at tomforti@verizon.net

 


#35
Ok here we go....

These errors are commonly caused due to memory errors or incompatability.
If you have two memory sticks try installing with only one by swaping each on each installation if it is still not working. try to change the sticks and see if it works
 


#36
Same problem here...

yeah well, i have my hp pavilion dv7-1468nr amd turion X2 64 2.2, 300 hd, 4 ram, ati hd 3200...

And i have exactly the same problem...
Error code: 0x80070017

Ill try the memory's stuff...

Question:: This problem is just with windows 7 or with all windows ¿?¿?¿?¿?
 


#37
It's nice to see that nearly a year after the last post this problem is still occurring... I have been having the same issue as everyone else except that I had windows 7 installed on my system and I am formatting my harddrive to get rid of all the junk I've accumulated over the past year. If anyone has found a solution to this can you please post it?

Thanks
 


#38
Re: posible workaround

I got the same error, but was able to fix it after playing all sorts of games with my RAM--turns out that having a certain stick in a certain slot will do the trick, and nothing else...for me at least, as everyone else has said, your mileage may vary.
 


#39
Re: posible workaround

I am installing from a flash drive. After many many hours/days of troubleshooting, and right as I found this forum I finally got it to work.

I re-named my flash drive to the name of the DVD, "GRMSXFRER_EN_DVD", for server 2008, and I made sure that I only had 1 stick of RAM in the primary slot on my motherboard and it worked like a charm!
 


#40
Ok here we go....

These errors are commonly caused due to memory errors or incompatability.
If you have two memory sticks try installing with only one by swaping each on each installation if it is still not working. try to change the sticks and see if it works
Thanks guys! There is a reason I always come to this site first.

Had a system that was massively messed up because of an anti-virus issue, so tried to do system restore. System restore failed repeatedly, so tried to do clean install. Clean install from USB didn't work with x64 or x86 versions that I have, although both have worked before. Kept getting 0x80070017 error even after wiping HD etc. Was about to jump out a window. Then tried the RAM swap, and it works!

If you are having the 0x80070017 on install, take out a RAM stick and try again, then if it still doesn't work, try the other one. It works!

You guys saved my sanity again :)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top