Ethernet Controller Problems

#1
I have done a clean install onto a Acer Aspire M1610 (Celeron) desktop computer using Windows 7 (32 bit). I'm getting the dreaded "Windows did not detect a properly installed network adaptor. If you have a network adapter, you will need to reinstall the driver."

I have only moved house recently and the drivers that came with the computer could be anywhere. :confused:

I am having problems locating the correct ethernet controller for this computer. After getting into the BIOS, the motherboard details are as follows;
Mainboard ID: F672CR
Bios Version: 6.00PG
Bios ID: R01-A3

I have gone into the Device Manager which has a mark against the ethernet controller. I have uninstalled and rebooted and it still comes up with the same problem. I have also tried using a Netgear WG111 wireless USB reader instead and it still won't connect. Comes up with a compatibility issue even when I choose VISTA in Troubleshoot Compatibility.

Any assistance would be greatly appreciated. I have sent an email to Acer Australia and I'm awaiting a reply (I don't hold too much hope of a descent reply).

Cheers
Laurie
 


Last edited:
#3
Something doesn't seem right there. I downloaded the 16kb file and tried running the zip file. I got the message "Please insert the last disk of the Multi-Volume set and click OK to cintinue".

It's got me there.........

Cheers
Laurie
 


iroken22

Extraordinary Member
Premium Supporter
#4
The file was 3.7mb not 16 kb. Look at the attached image for the appropriate driver to download.
 


#5
Yep, that's the one, I click SAVE and it's 16kb in size and takes 1 sec to download. I'm going to reboot the computer and try again but I don't think that will change anything.

Cheers
Laurie
 


#7
You are a legend. Installed, rebooted and all is good.

I can't thank you enough. 2 days I've been trying to get that to work.

All the best.

Cheers
Laurie
 


#8
Windows7 Ethernet controler prbolems

Hi thanks for reading this, I have a problem, ijust got windows 7 today and I can't connect to the Internet , I had xp yesterday,connects no problem the other two pc's in the house connect fine, even the xbox360...... So I went to control panel, device manager, ilooked down and I saw Ethernet controller withe a yellow triangle and a !, so I scaned my c drive to see if there was a driver it found , SiS900 - based pci fast Ethernet adapter, nut it encounters an error when installing, my mo is - k7s41gx. Thanks if you can help me and I really need help
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
#9
I did a little googling and some have had success using that driver with win 7. (As your probably aware the last driver release was for xp only)
Download the driver from here: http://www.sis.com/download/download_step1.php?id=153181
Before you install it though, rightclick on the start up exe and choose properties. Then look along the top for compatibility and change it for xp. Let me know how you get on..
 


#10
Thanks , but sorry,

just b4u sent this , i just got connected, i downloaded the Sis 900 driver for the ethernet connection, it works, Thank you so much!!!! . ;):redface::D
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
#11
Excellent! :)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top