Explorer.exe Class not registered

Davii

New Member
So hey guys, I'm in a bit of a sticky situation here. So I booted up my computer on Monday, loaded fine and everything seemed to work until i tried opening the file explorer, when boom error message.

37444


Being an Com Sci major and having some experience with viruses and windows misbehaving, I went straight into trying to trying to fix my issue, but it wasn't as simple as i thought it would be.

Firstly i did a complete scan with Malwarebytes and it found 'Legit.BatBitRst' which is an adware trojan. Malwarebytes got rid of it and i thought my problem was solved. No it wasn't.

So i went online looking up this issue. Found that i might just need to re-register the explorerframe.dll. That didn't work either:

37445


So in doing some more reading i saw were it might be some windows feature settings related to IE and Edge so i tried opening control panel:

37446


I even tried windows update to see if that would help but when i click update and security in settings, it just quits.

I've tried sfc/scannow which said that some files are corrupted but it couldn't fix them, did the dism/online thing after which completed successfully but didn't solve the issue after running sfc/scannow again.


Only things that I have not tried, is doing a clean boot, or a safe boot; and a deep administrative scan of the App Data, Program Data, and Windows folders, by Eset Smart Security came back clean.

So i'm at my wits end, any help with this issue would be greatly appreciated.

Windows 10 Enterprise x64
Intel i5-3210M 2.6GHz(3.0GHz)
Nvidia GT635M 1GB
8GB RAM (7.9 usable)
700GB HDD
 
Last edited:

Neemobeer

Windows Forum Team
Staff member
You could have other malware or the one you removed replaced DLLs and those may be gone or it could simply be a registry problem. I would boot to the recovery console and roll back to a system restore point prior to the issue and see if that resolves the problem.
 

Davii

New Member
Hi, thanks for responding. Most likely its that the one I removed messed up the dlls, I tried the system restore from the recovery console but it failed. Said that it wasn't able to extract some dll file.
 

Neemobeer

Windows Forum Team
Staff member
Then I would suggest re-installing Windows. You can select the "Keep personal files and programs option".
 
Top