Explorer.exe error

#1
Hi to all,

i installed Win 7 and if i try to open my computer of click on desktop and open up screen resolution etc.... i get Explorer.exe -Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item.

I did a search but could not find anything related to this error in Win 7. I have found some others attached to Win XP but have to do with the installation of some software which prevents access to explorer.exe

Any ideas on this? When i boot in safe mode this issue does not appear...


thx in advance.
 


#2
Re-Install

Hey,
I've installed Windows 7 on Multiple Computers, no problems at all
So I would suggest just a simple re-format, make sure it is a clean install (format partitions, not upgrade)
Hope that works
 


MCSE

New Member
#3
Not an install issue

I performed a clean install and I have the same problem. I installed it on a weak little old Sony Vaio. I just did the install so I will resolve the problem and let you know.
 


#4
When exactly does that message pop up? When you open explorer.exe ANYWHERE (also control panel), when you try to access a specific drive, ... ?
 


MCSE

New Member
#5
Yes the message appears when you attempt to enter control panel, my computer....just about any time you launch an explorer window. The message is then fallowed by a message that explorer.exe is restarting. However the restart never completes. I manual launched explorer with the same result. I will add more feedback when I have some time to play with it.
 


#6
that's strange ... especially when you consider that explorer.exe is ALWAYS running in the background, so it shouldn't matter whether you visually launch it or not.
two things you might wanna try:
1) try opening explorer.exe as admin (hold crtl+shift and click on an icon that opens explorer.exe) and see if that works
2) see if you can use cmd-windows (startbutton->search "cmd"->click on cmd.exe) and see if you can see/access your files/folders from there

if you manage to open explorer.exe in 1) go to your windows-folder and try changing the permissions for explorer.exe, though I doubt that'll help
 


MCSE

New Member
#7
I have already done all of that.

Do not fret on it to much I will play with it later.
thanks
 


Last edited:

MCSE

New Member
#8
Finally looked at this....and fixed it

I finally had time to fix this.
It's easy, you need only select start and then run and type secpol.msc to open the UAC controls. Then go through and turn off all of the admin restrictions and reboot. You can then do as you please and go back and re-enable some of the UAC controls for your own safety.
 


#9
Something else to try

You could also try opening a new process for explorer, because Windows 7 allows you to have multiple explorer processes running at once. Just hold shift and Right-Click my Computer, and then Click Open in a New Process

its not a complete fix, but may help
 


#10
Thanks.....but already fixed

Thanks,
However as I said in the post above yours I already fixed this issue. FYI I had already tried what you said a few weeks ago and it did not work.
thanks any way.
 


#11
I recently had the same problem. My solution was to create a new user, for me atleast the issue was with the user somehow.
 


echo

New Member
#12
exactly which UAC admin controls do i disable, im having the same problem too, screenshot would be great
 


#13
I had the same problem with my explorer not opening. i got frustrated and rage quit for a bit, lol! Anyways i figured it out. Go to Start, then programs, then you will see 2 different internet explorer options. One is a 64 bit version and the other is a 32 bit version. More then likely your explorer is set to the 64bit xersion upon install with win7. I just selected the 32 bit version and it worked. so i then deleted the shortcut for the 64bit version i already had on desktop and then created a new 32 bit version shortcut in its place. i hope this helps you. i didnt have any help when it was my problem, hehe.
 


#14
just before i reply to this thread i was facing same problem but i m able to solve this problem with out reinstalling windows 7. its simple ...
1. click start menu then type restore
2. u will find system restore in the list .. right click and run as administration
3. now run this system restore in earlier setting .. hope it will work...
 


#15
when i click on Downloads that is in the left panel of any folder then it shows

explorer.EXE

The file does not have a program associated with it for performing this action. please install a program or, if one is already installed, create an association in the default program control panel.


and i can't open Downloads from here. Every time i want to open Downloads I have to go C:>users>suman>my documents>downloads.

please tell me how to fix it, i don't want to reinstall a fresh copy of windows 7.
 


#16
Re: Thanks.....but already fixed

Post #8 worked for me. Here is some additional info for anyone else frustrated with this problem. I had a perfectly working Windows 7 computer, when one day the same problem happened to me. Explorer.exe would not run - "may not have permissions...". Wireless internet would not connect. I could not open control panel or computer. I had to boot into safe mode and add a new administrator user. Then I set UAC to the lowest level with the program "Change User Account Control Settings", not secpol.msc, and restarted the computer. This allowed me to use my original user account.

After rebooting, if I reset the UAC settings, the problem would return to the original user account. The new user account still worked with the stricter UAC settings. Annoying to have to transfer all my settings over.

I wish there was a way to repair a broken user account. And I wish I knew what causes this in the first place.
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top