Font Not Installing Properly

#1
I'm having a strange problem that I only had once before and was unable to fix on Windows 7. Now I'm getting the same issue on Windows 8. Last night I downloaded the font Roboto (used by Google for their Android UI) and all of the weights installed properly, except for the Regular and Regular Italic weights. Trying to re-install the weights prompts a query if I want to replace them. Under the Control Panel's Fonts area, there are two ghost-like icons that would indicate the presence of the missing weights, and when I check for the fonts using "\\localhost\c$\Windows\Fonts" I see them there (all copies). Furthermore, despite being the Administrator of my computer, I can't seem to delete them from this area. All my hidden files are turned on, so I'm not sure what else to do. Please see the photos below for visual description of what I've been talking about. Does anyone have any other ideas? This is really frustrating me. Thanks!

Font Problem 0.jpg
Font Problem 1.jpg
Font Problem 2.jpg
Font Problem 3.jpg
 


#2
One other thing. When this happened last time, I installed the problem fonts on my work computer and they worked fine, so I don't think it's an issue with corrupt fonts.
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#3
Hi

Do you have the UAC turned off.
If not try that and then try deleting them again.

You could try activating the Administrator Account and see you can remove and reinstall them from there.

The following was written for Windows 7 you can get to the prompt from the metro screen.

How to Enable the Administrator Account

Open the command prompt with elevated privileges by clicking the Start orb, All Programs, Accessories, right-click Command Prompt and then select Run as administrator.

Type or cut and paste…

net user administrator /active:yes

and then press Enter.

Log out and log back in as Administrator.

When you are done undue the process by doing the same thing and pasting in

net user administrator /active:no

T
his should get around the permission issues.

I don't know why the font didn't' install correctly to start with, the only times I've run into that the files were corrupted and redownloading fixed it.

I just downloaded and installed them from this location and they all installed fine.

http://www.fontsquirrel.com/fonts/roboto

Mike
 


davidhk129

Senior Member
#4
rmintzes,

Go back to Default font settings and start from scratch............
Go to Charm bar ( Win logo + C ) > select Start > anywhere inside the screen, type Fonts > select Change font settings > click Restore default font settings > OK when done.
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#6
Hi

Have you tried getting the font from a different source?

http://www.dafont.com/roboto.font

This sounds like your computer is seeing several different weights as as being the same thing.
There's a chance that a font compiled by a different source could work, if you can completely remove the old version first.

You could also try installing the fonts on a different computer and just copying the fonts to your computer's fonts folder and bypass the install function all together.

I always make a folder called "Fonts Used on My Computer".
I just copy the entire Windows Fonts folder with all of the fonts I have added to it.

When I get a new computer or have font issues, I just copy this folder to the Windows directory in my new one, and all the fonts are there and working with one copy and paste. It merges any new fonts that are on the new computer with the ones I have added.

You can tell it to overwrite existing fonts or leave the original fonts in place.
I usually just tell it to overwrite everything.

In your case I'd try and remove the fonts installed on your computer and then paste in the ones from the donor computer, directly into the Windows fonts folder.

It's interesting to note that the font install process isn't really necessary, I assume that Windows adds the new fonts to the appropriate place in the registry on it's own somehow.

I notice that you are accessing fonts by a rather round about way going through control panel from network etc.

I have no idea if it would make a difference but try and access them directly in the Windows Fonts Folder and see if it helps.



Mike

Let us know what happens.
 


Last edited:

snrlcd

New Member
#7
I have tried that option. So there is a Roboto from three diferent sources.
None of them solved it. The onli thing left is to try using roboto from another computer.

 


Last edited:

snrlcd

New Member
#8
Hi

Let us know what happens.
Hi Mike, I have tried your solution with copying from another computer with no success.
I have recently upgraded from windows 7 to 8, and think that may be the cause of font problem.

I have tried above solutions and from another forum, if I ever come across a solution will post it here.
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#9
Hi

Thanks for checking back in.
I don't have any idea what's going on, I've never had a problem like this.

I've had a few corrupted fonts over the years, and I've had a lot of fonts, (I'm a graphic designer) but never one that won't work on one specific computer.

You might be interested in this....

http://theunderstatement.com/post/11645166791/roboto-vs-helvetica

I hope you do find out what's causing it one of these days.

Mike
 


#10
I was having the same issues, so I used an online ttf -> webfont converter. It gave me a new copy of the ttf version of the font. Whatever metadata it changed, it seems to have worked. Here's a copy of the converted fonts:

http://files.jjcm.org/Roberto-Regular.ttf
http://files.jjcm.org/Roberto-Regular.otf


Try the ttf first. If you're still having issues, give the otf a shot.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.