Windows 7 Games Crashing Entire PC

Discussion in 'Windows Games' started by wil, Jan 11, 2011.

  1. wil

    wil New Member

    Joined:
    Dec 27, 2010
    Messages:
    38
    Likes Received:
    0
    Hi,

    I posted an issue a week or two ago about my call of duty 4 game crashing my entire pc and also call of duty 2. After trying the suggestions given by the helpful people on this forum, nothing seemed to work. I gave up on it thinking it would just be Call of Duty not working but just the other day I go out and buy Battlefield Bad Company 2 and the same thing happens....I get into single player games fine, but once I play some multiplayer it will freeze after a random amount of time. This is just incredibly frustrating having bought the game hoping to play it and having this happen to me again. Help is much appreciated.

    Thanks

    Here is a link to the other post I made on this issue if that helps.
    http://windows7forums.com/windows-7-games/55358-call-duty-4-crash.html

    Im running windows 7 x64.

    here are my pc specs:

    Processor: Intel Core 2 Quad CPU @ 2.40GHz 2.40GHz
    Installed memory (RAM): 8.00GB
    System type: 64-bit Operating System
    Video card: NVIDIA GeForce GTX 275
    Motherboard: Gigabyte GA-965P-DQ6
     
  2. Firecracker

    Joined:
    Jan 19, 2010
    Messages:
    405
    Likes Received:
    4
    I've been looking into this further, But I Have CoD4MW and BFBC2 On Windows 7 64bit (x64) and Runs fine no problems at all, Been talking to fellow Gamers none of then seem to have any problems with these games, and they have Windows XP 32bit, Windows Vista 32 and 64bit and Windows 7 32bit and 64bit, however the marnority of them have Windows 7 64bit, We had a computer at work with the same specs, and it had the same thing, we buged, replaced stuff, you name it and the games won't work, I would say it is something in the programing of the games or the Operating system, this isn't the first time this has happened, it has happened in the past and it is be coming a constant issue, No one really know's what is causing this. As I have said though, it is patchy, these games Work with some computers and not with others, which is strange :( Have you considard the Network adaptor(s) might be cactus? Go down to a place which sells computer gear, and buy a PCI-Gigabit adaptor install it, Install the drivers and play the games, Prefurably buy one that has a Marvell or a Realtek GBe Chip.
     
    #2 Firecracker, Jan 11, 2011
    Last edited: Jan 11, 2011
  3. wil

    wil New Member

    Joined:
    Dec 27, 2010
    Messages:
    38
    Likes Received:
    0
    Oh thats not what I wanted to hear :S

    Okay I'll do that. I'll go and buy a PCI-Gigabit adaptor and do as you suggested and see how that works. Thanks
     
  4. wil

    wil New Member

    Joined:
    Dec 27, 2010
    Messages:
    38
    Likes Received:
    0
    Hey friend told me to take out the high def tv card and move my pci wireless card into that slot which may fix the problem. Did it and was working beautifully. Thought I had it fixed. Played for a few hours so problem but then all of a sudden it happens again. So I'll still buy a PCI Gigabit adaptor and see if that does it.
     
  5. Firecracker

    Joined:
    Jan 19, 2010
    Messages:
    405
    Likes Received:
    4
    Checking to see what's up, haven't herd for few days, seeing if that worked.
     
  6. wil

    wil New Member

    Joined:
    Dec 27, 2010
    Messages:
    38
    Likes Received:
    0
    Thanks for the check up but I'll let you know first thing next week. I'm down at the beach at the moment so as soon as I get back I'll but a gigibit adapter and see how it goes. Also before I left i tried using ethernet cable to see if worked but it didn. I uninstalled the wireless card software and using ethernet cable, didn't work. I also then tried removing the card and trying with ethernet but didn't work either. So once I get the gigibit adapter I'll try similar thing if it doesn't work by itself and let you know.

    Thanks. Will
     
  7. Firecracker

    Joined:
    Jan 19, 2010
    Messages:
    405
    Likes Received:
    4
    Dunno if you a aware but SP1 for Windows 7 is avaliable now. try installing as what Mike has put up. see if that works too.
     
  8. wil

    wil New Member

    Joined:
    Dec 27, 2010
    Messages:
    38
    Likes Received:
    0
    Well finally I have it fixed..well I hope it is. Been playing few hours today and no problems so I think its all good. I just found this on a battlefield bad company 2 forum which worked for me:

    What I did was uninstalled my audio drivers, rebooted, then did this:

    ALL CREDITS GO TO DeaF.TonE - Thank you very much
    1.go to start menu
    2.then accessories
    3.then command promt
    4.right click and run as admin
    5.it will cm as c:\windows\system32
    6. if not then type cd c:\windows\system32 and hit enter
    7.then it will cm c:\windows\system32
    8.then type sfc /scannow and hit enter please do not interupt this process untill its finished and it will fix ur problems it fixed my two problems and now am playing flawless(space is reuqred between sfc and / then no space its conti...)
    9. if u r having on board realtek sound card turn it quality to 16bit 44000khz means it will be last quality
    10.enjoy

    and last thing i did was installing these realtek drivers:
    Vista_Win7_R250_x64

    downloaded:
    Realtek

    click checkbox to approve and then download the one u need.



    Thanks for all the help
     
  9. Firecracker

    Joined:
    Jan 19, 2010
    Messages:
    405
    Likes Received:
    4
    Has it stayed fixed this time? Sorry we are a bit late, seems everyone has there head stack into Windows 7 SP1 leak :)
     
  10. wil

    wil New Member

    Joined:
    Dec 27, 2010
    Messages:
    38
    Likes Received:
    0
    Yep seems to be. Thanks for all your help.
     
  11. Firecracker

    Joined:
    Jan 19, 2010
    Messages:
    405
    Likes Received:
    4
    That's a pleasure, come back will ya if you have anymore issues won't you. We won't be going anywhere anytime soon. :)
     

Share This Page

Loading...