Windows 7 Games that Work and Games that Don't.

#61
hey people,

has anyone managed to play Sims 3 yet??
 


#62
Compatibility mode maybe?

Background: I installed 7 on an older XP box running on a Athlon XP 2800+ with 3gb PC400 and an nVidia geForce 7800. All of my newer games ran fine at mediocre to medium settings on XP.

Currently going through and installing the games on Windows 7 now. What I have so far:

Fallout3: Installed fine. Ran great for about 20 minutes.
Problems: 1. Graphics were...in a word...weird. Graphics were blocky, but the facial features were better defined than when running on XP. Boosted the settings but had the same issues.
2. While the game was still running...and runing jus fine...I got a pop-up error box stating that Fallout3 had stopped running and windows was trying to determine why...but it was still running and still responding to keyboard/mouse commands.

Mass Effect: This is the most disheartening, since it is my favorite game right now.
Problem: Will not install. Gets to a point and says it cannot open a particular file.
Attempted solutions: Run as administrator: No Luck.

Any help with ME from those who succesfully installed it would be greatly appreciated. I will post updates as I try installing/running more.

Next attempt to install...failed at the same file.
Problem:
Still not installing...gets to a point and stops.
I copied the disk to my hdd so I could run it from there as admin. It got to the same point as when installing from disk and stopped.
The Error: The error box says:
Error opening file for writing
C:\Program Files\Mass Effect\saferun.dll

I notice you mentioned you tried running as administrator, however, have you tried changing the exe's to run in compatibility mode?

For instance, with Mass Effect, the files you copied to your HDD would include a setup file, correct? Try right-clicking on "setup.exe" and select properties. Then go to the compatibility tab, and try to run it in compatibility with maybe XP SP3 or even Vista SP2 (on top of running as admin).

Hope this helps, let me know if you've already tried this or not.
 


#63
As promised....

Xmen Wolverine Origins.

working.


AND IT ROCKS!


look for a good iso thought, someones stuck after chapter 3, or throw blank screen or no audio etc etc.

just read the comments =)

as soon the NFS`s are done, i will test them.


=)
 


#64
As promised....

Xmen Wolverine Origins.

working.


AND IT ROCKS!


look for a good iso thought, someones stuck after chapter 3, or throw blank screen or no audio etc etc.

just read the comments =)

as soon the NFS`s are done, i will test them.


=)
you should mention wich beta you are using,

i'm using 7077 x64 and X-Men Origins: Wolverine works just fine.
 


#65
Warcraft 3 and Frozen Throne
GTA San Andreas
GTA Vice City
Age Of Empires 3 /WarChiefs/Asian Dynastes
Counter-Strike 1.6


All those ran for me well.


Used 64-bit Windows 7 RC
 


#66
Windows 7 64-bit RC

Working:
Warhammer Online: Age of Reckoning - absolutely not one issue with the game, perfection!

Not working:
Fallout 3 - Freezes after playing for so long, ive looked online for a solution, no avail. If anyone has tips please shed some light.

Warhammer 40k: Dawn of War 2 - this one id love to get working, i really want to play it badly, it does the exact same thing as fallout 3. I can play it for so long, and then bam, it freezes. My PC is more than strong enough to run the games at max, yet i freeze randomly. Music still plays, sounds etc, the screen is just frozen and locked. Even in vent i can still talk to people.. its strange.. Anything i can try? (I can't run Warhammer 40k as admin, because its in steam for some lame reason. Any way to take it out of steam?)
 


#67
im just moving from xp to win 7 :
ShellShock 2 : Blood Trails & The Sims 3

Both working like a charm. Running smooth and crystal clear. No freezes etc at all
:)

Also : C.S.I : NY , Super Bike World Championship 09 , Need For Speed Underground 2 & Zuma Deluxe tested today & works all.
 


Last edited:
#69
NASCAR 2003 and all mods I have loaded
ARCA Sim Racing
Using 7100 RC x64 and x32

Rock on

BillD
 


#70
One more i just playin' : Killing Floor (Survival Horror) : Result = Working. :razz:
 


#71
I don't know if this has been posted already but I just found out that Neverwinter Nights 2 does not work straight up in Build 7100. It'll give an error message about not being able to detect your video card. There is a workaround (you have to download a .dll file or two) or I've heard people being able to run it with Build 7122.

For Mass Effect, I'm just fighting the horrible load times when I load up the game. It loads up slightly faster if I run it in windowed mode but the performance sucks. On the other hand, fullscreen performance is smoother but the load up time is ridiculous. On top of that, doing Alt-Tab will lock the game up forcing an "End Task".

Speaking of Alt-Tab, I'm still facing that issue with Fallout 3. Also, it crashes after a while which is somewhat frustrating (I've done all the updates).

I'm gonna go ahead and try some more games out now that I have a better video card.
 


Last edited:
#72
hey @SLiM PiCKiNS how did Farcry 2 work
it doesnt work for me
hey what exactly was the problem? i'm running 7077 now and i havn't really installed much.

some details please would be helpful, ie. which build are you running? is it x86 or x64? and what exactly was the problem? did the installer not run at all or does it install then crash when you try to run it?
 


#73
hey people,

has anyone managed to play Sims 3 yet??
Sims 3 runs awesomely on build 7077 x64 so far. the graphics in the actual game are slightly better than sims 2, not by much though. and it's not too heavy on system resources.
 


#74
I just got Windows 7 setup the other day and havn't had a chance to install very many games yet...All of the games I have installed so far work marvously well except for one...Rise of the Argonauts which I posted a thread about the problem here : http://windows7forums.com/windows-7-games/6252-rise-argonauts-will-not-install-please-help.html

These are the games that work great so far....None are in any kind of compatability mode.

Chronicles of Riddick : Assault on Dark Athena : (I havn't tryed playing the original game that installed at the same time with the sequel.) Plays really well ZERO problems.

Age of Conan : Installs and Plays very well!

Runes of Magic : Installs and plays great in Window mode (For some reason I got an error mssage when I tryed to play in full screen ..... Cant remember if it was the same way when I set it up on Vista.
 


Last edited:
#75
Work:
Rf online
L4D

Not Work:
Cabal online ~ Xtrap issues (anyone can help me fix it)
 


#76
I have good news about Rise of the Argonauts the problem with installing the game was all my fault The CD had a tiny smudge of gunk and once cleaned the game installed with ZERO problems. It also plays ok except for some sound issues that hopefully I can get worked out....I don't believe it is a Windows problem though as this game still has many bugs that need to be patched.

Rise of the Argonauts... Installs and Works on Windows 7!
 


Last edited:
#77
The Witcher EE installed with ZERO problems and plays with ZERO problems!!! I installed The Witcher with the original CD and Patched to TWEE from the net.
 


Last edited:
#78
Xmen Origins:Wolverine installed last night and played about an hour....Works great!! Rockin game too!!
 


#79
Anyone solved the problem with crashing games?
All games i have installed are crashing after 20 mins or so.
GFX card overheat or driver problem?
Ideas?
 


seekermeister

Honorable Member
#80
CoD & MoH AA BSODs

I'm just getting started with a new installation of W7 (B7100 x64), and the first two games that I tried to run ended up with a BSOD before the games actually started. I don't have a debugger installed yet, so I can read the dump files, but the Event Viewer describe them as follows"

Log Name: System
Source: Microsoft-Windows-WER-SystemErrorReporting
Date: 5/29/2009 2:52:27 AM
Event ID: 1001
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: Newhope
Description:
The computer has rebooted from a bugcheck. The bugcheck was: 0x0000003b (0x00000000c0000005, 0xfffff96000172a4f, 0xfffff880073ca050, 0x0000000000000000). A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: 052909-29453-01.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-WER-SystemErrorReporting" Guid="{ABCE23E7-DE45-4366-8631-84FA6C525952}" EventSourceName="BugCheck" />
<EventID Qualifiers="16384">1001</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2009-05-29T07:52:27.000000000Z" />
<EventRecordID>2754</EventRecordID>
<Correlation />
<Execution ProcessID="0" ThreadID="0" />
<Channel>System</Channel>
<Computer>Newhope</Computer>
<Security />
</System>
<EventData>
<Data Name="param1">0x0000003b (0x00000000c0000005, 0xfffff96000172a4f, 0xfffff880073ca050, 0x0000000000000000)</Data>
<Data Name="param2">C:\Windows\MEMORY.DMP</Data>
<Data Name="param3">052909-29453-01</Data>
</EventData>
</Event>

Scanning through this thread, I read where that one person did get CoD to work, but he didn't indicate which build or architecture, so that may be why it worked for him, and not myself. I normally wouldn't bother posting a question such as this, and simply relegate the games to the shelf, but two in a row seemed to indicate a problem that may keep popping up. I did set CoD to Vista SP2 compatability, and it made no difference.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.