Getting a keyboard layout I don't even have in the control panel

Discussion in 'Windows 7 Help and Support' started by Oskar K, Jun 7, 2014.

  1. Oskar K

    Oskar K New Member

    Joined:
    Jun 7, 2014
    Messages:
    2
    Likes Received:
    0
    Hi!

    I'm using two keyboard layouts: Colemak and a Russian one, and those are the only 2 layouts I selected in the control panel. When I play StarCraft 2, sometimes, suddenly and without any kind of warning, my keyboard layout changes to regular English Qwerty. Pressing Alt+Shift switches between Qwerty and the Russian one. I haven't used Qwerty (or even had it in the control panel) for weeks! Why is Windows doing this to me?
     
  2. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Joined:
    Mar 1, 2012
    Messages:
    2,499
    Likes Received:
    211
    Probably a Game issue. I'd check the settings there.
     
  3. Oskar K

    Oskar K New Member

    Joined:
    Jun 7, 2014
    Messages:
    2
    Likes Received:
    0
    No, it's not a game issue. I'm 99.99% sure it's a Windows issue.
     
  4. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Joined:
    Mar 1, 2012
    Messages:
    2,499
    Likes Received:
    211
    Playing a game, it's the game that rules - Windows is sort of in the background. You could find some hints in https://us.battle.net/support/en/article/starcraft-ii-language-issues

    Possibly, you have a lack in the language file. Has it ever played well? If you have the proper language files, all is installed properly, there is no need for Windows to interfere.

    Best of all.
     

Share This Page

Loading...