ICS works in XP/Vista, not in W7.

Discussion in 'Windows 7 Networking' started by cappadonna, Nov 3, 2009.

  1. cappadonna

    cappadonna New Member

    Joined:
    Nov 1, 2009
    Messages:
    8
    Likes Received:
    0
    Hello all. I have been on a 5 day quest to solve my issue but cannot seem to find the answer:( Here is how I'm set up.
    CDMA internet connection through USB. NIC address on PC is 192.168.0.1. NIC runs to LAN port on wireless router (WRT54G2) that has an address of 192.168.0.254. Under 'Advanced Routing' tab 'Router' is enabled. All settings on router are DHCP. This works flawlessly with XP and vista. I can share my CDMA connection wirelessly or wired and Xbox live, PSN and Wii store all work great. Then comes W7 and none of the above work. All settings are tit for tat accross all 3 OS's.

    If someone has any suggestions or a solution it would be greatly appreciated:) Many thanks in advance. I'll post my solution if I can ever get it working.......doesn't look good though.
     
  2. cappadonna

    cappadonna New Member

    Joined:
    Nov 1, 2009
    Messages:
    8
    Likes Received:
    0
    Anyone? I've searched every windows 7 forum I can find. The best I can get is "Oh I fixed it" and no one wants to post how they fixed it. Many thanks.
     
  3. sowrov

    sowrov Guest

    I was in the same problem as you, so search the web, find your post but as all other with no solution!
    Anyways so I figure out the solution myself :p

    And it is actually easier than XP/Vista!
    so here is what i did.
    1. Enable the share option in my host pc's internet connection and I found that by default windows7 set my other lan card's IP as 192.168.137.1 (which was 192.168.0.1 in XP/Vista). This time I agree with w7 and don't change the ip to 192.168.0.1.

    2. In my client pc's lan connection properties (IPV4) I select "Obtain an Ip address automatically"! (hmm ;) )

    3. My host PC's firewall said someone from 192.168.137.xxx is try to access Bla.. Bla.. I allow it ...

    4. And Boom... Now I am typing this reply From my Client pc!

    5. Have fun :D
     

Share This Page

Loading...