Router works in ubuntu but not in windows 7, Network driver issue?

Discussion in 'Windows 7 Help and Support' started by blackmajik2021, Jun 13, 2010.

  1. blackmajik2021

    blackmajik2021 New Member

    Joined:
    Jun 13, 2010
    Messages:
    4
    Likes Received:
    0
    Im running ubuntu and windows 7 on a compaq preasario Sr5210nx. connecting wirelessly to a linksys WRT160Nv2 using a linksys WUSB600N usb adapter. Im using the exact same WPA2 setting under ubuntu and windows 7, but windows 7 wont connect (ubuntu connects automatically / flawlessly)

    in the connection settings window, Windows 7 says that im not using the right type of encryption settings for my router. it says "you are using WPA2 which is not the right type of encryption, please choose the appropriate type for your router" but I AM using wpa2......

    I tried to update the drivers but compaq makes no windows 7 drivers for my model...and the windows vista drivers would not install...windows installed drivers automatically and it says they are all working properly

    at one point my computer connected to the internet, and was connected for a few days until i shut down the computer....while it was connected windows still showed me an "x" over the wireless connection icon, and in my network settings indicated that i was not connected to the internet (even though I was browsing the web)

    help please....This is driving me insane, ive been trying to fix this for weeks.
     
  2. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    It is possible the connection settings are corrupted one way or the other. What you can do is delete the pre-defined entry for this wireless connection from the Wireless Connection Manager. Right-click on the icon in the system tray, and you will be able to pull up a list of all of the saved WiFi spots you have ever connected to. Simply remove this one, and try reconnecting again, inputting all of the password information over again.

    This may allow you to connect successfully, as if you have made a transition from a former type of encryption Windows may not pick up on it and think your wireless router is using a different type of connection.
     
  3. blackmajik2021

    blackmajik2021 New Member

    Joined:
    Jun 13, 2010
    Messages:
    4
    Likes Received:
    0
    thanks mike! that got me back to having my SSID show up with signal bars ( full signal) , but now it keeps rejecting my password, even though im typing it in correctly. I've logged into my linksys control panel to double check everything and the passphrase is correct. WPA2 personal...

    this was my initial problem...it kept rejecting the passphrase

    EDIT:

    windows is auto-detecting in the available networks that my wireless connection is WEP ( though my router is set to WPA2)

    I cant find a way to adjust that setting ( on windows 7's end ) without making a connection manually. When I manually set it up, the full signal goes away, replaced by a red X. When I remove the connection (like you recommended) a full signal returns showing that my available network is WEP. At screen where i enter the password windows shows me that i may also press a button on the top of the router, however, when I do so, I get the same problem as when I try to make a manual connection ( the signal bar turns into a red X and says i have incorrect settings)
     
    #3 blackmajik2021, Jun 13, 2010
    Last edited: Jun 13, 2010
  4. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    You may have setup, by accident, more than one connection.
    If you clcik the Notification area icon, does it show more than one available connection?
    If so, try this.
    Open the Network and Sharing Centre (Text at the bottom of the opened icon window)
    Click "Manage Wireless Networks"
    Now, if you are 100% certain which one is your correct connection, right click each of the others and "remove" them.
     

Share This Page

Loading...