Windows 7 Inconsistent problems using Citrix

Discussion in 'General Computing' started by MetroBOS, Nov 11, 2014.

  1. MetroBOS

    MetroBOS New Member

    Jun 4, 2014
    Likes Received:
    I use Citrix to connect to my office computer from my home computer.

    For the past couple of weeks, I've been having trouble connecting. Sometimes it works, but more often it does not. The error message I get says the following:

    "The specified remote computer could not be found. Verify that you have typed the correct computer name or IP address, and then try connecting again."

    I know I am typing the correct computer name because it's saved in my dropdown list. As far as I know, nothing on my office computer or home computer has changed, but the problem is inconsistent because sometimes it connects and sometimes it does not.

    Basically, the steps I am taking are as follows:
    1. Go to citrix.[company].com
    2. Enter my user name and password and click log in
    3. Click desktop
    4. I get a pop up message saying I have chosen to open launch.ica which is Citrix ICA Connection from http://citrix.[company].com. What should Firefox do with this file?
    5. I choose to open with Citrix ICA Client Engine Win32 (default)
    6. Then I get another pop up message saying that this program has known compatibility issues and that Citrix ICA is incompatible with this version of Windows. - This is the same message that always pops up and it's always worked before.
    7. I click Run Program
    8. It brings me to a generic looking desktop running Microsoft Windows Server 2003 R2
    9. I then click on the Start Menu and choose Remote Desktop Connection
    10. I select my office computer's name (which is entered by default) and click Connect

    That's when I get the error message.

    Does anyone know what the problem could be and how I can find a resolution?
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Aug 28, 2007
    Likes Received:
    Have you tried re-installing Citrix or seeing if any updates/later versions are available?
  3. Trouble

    Trouble Noob Whisperer

    Nov 30, 2009
    Likes Received:
    It would seem from the above that perhaps your problem is not with the ICA client you are using to connect to the server, but.....
    more likely name resolution on your office network after having connected to the office server and then using RDP (mstsc.exe) to connect to your office computer from the server in your office.
    Determine what your office network is using for name resolution.
    A local DNS server or a WINS server?
    And make sure that both the server you are Citrix-ing into and your computer that your RDP-ing into are both pointed to either or both for name resolution on the office network.

Share This Page