keys type numbers instead of letters

Discussion in 'Windows 8 Help and Support' started by wilmer007, Mar 10, 2015.

  1. wilmer007

    wilmer007 New Member

    Joined:
    Mar 10, 2015
    Messages:
    4
    Likes Received:
    0
    this is for windows 8.1

    I built my desktop about 6 months ago and it gets annoying every time i turn it on this happens.

    keys such as jkluiopm end up typing like this instead: 123456-0

    my only fix so far has been to unplug the USB keyboard and re plug it but i hate having to do this.

    i am wondering if there is a fix to this so i don't have to unplug and re plug anymore.


    i don't have the FN key and i have tried things like holding shift + numlock or control + numlock and nothing


    help please
     
    #1 wilmer007, Mar 10, 2015
    Last edited: Mar 10, 2015
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,831
    Likes Received:
    1,565
  3. wilmer007

    wilmer007 New Member

    Joined:
    Mar 10, 2015
    Messages:
    4
    Likes Received:
    0
    i tried all of those. nothing has worked.
     
  4. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,051
    Likes Received:
    302
    Hi

    Can you try another keyboard?
    Just to be sure this isn't related to the keyboard somehow?

    The fact that it starts after unplugging it and plugging it back in seems to indicate that it isn't loading the drivers correctly.
    You could try going into Device Manager and uninstalling the keyboard.

    The keyboard will stop working at that point.

    Then reboot, this will force Windows to reinstall and reconfigure the keyboard.

    This may fix the problem.

    Mike
     
  5. wilmer007

    wilmer007 New Member

    Joined:
    Mar 10, 2015
    Messages:
    4
    Likes Received:
    0
    sorry for taking so long to respond but i still haven't been able to fix. i have tried everything and i also tried uninstalling and restarting.


    this also happens if i put the computer to sleep. sometimes i get very lucky and the numpad light is off when windows starts and i don't have to go and unplug. but for the majority of the times when windows restarts or i turn off the computer the numpad light is on most of the time when it boots which means i have to go and unplug.


    this is really getting to be a pain as i hate having to go under my desk all the time just to unplug and replug to get it working properly.



    i usually leave my computer on 24/7 for this very reason so i don't have to go and unplug every day. but i end up paying a higher electric bill as a result and slowly killing my desktop everytime i leave it on when i shouldn't be leaving it on.

    Reinstalling Windows won't fix it either because ever since i built my pc, i have reinstalled windows multiple times (did a reinstall about two weeks ago) and the problem is always there.

    i hope a solution can be found soon.
     
  6. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,410
    Likes Received:
    363
    If re-installing Windows does not fix the issue, then I would also say try replacing the keyboard. Should be able to return it if it doesn't resolve the issue.
     
  7. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,051
    Likes Received:
    302
    Hi

    Not a very elegant solution but you could get a USB Extension Cable and put one end someplace where you can reach it from where you are sitting, i.e. Velcro it to the edge of your desk.

    Then at least when it happens you could just unplug it and plug it in again without getting up from your chair.

    http://www.amazon.com/AmazonBasics-USB-3-0-Extension-Cable/dp/B00NH134L6/ref=pd_sim_147_3?ie=UTF8&refRID=0RP5N05AAF1YAXW8T0MF

    As to what's causing it, I don't really know since it works and then doesn't, it sounds like Windows just isn't loading the service or drivers when it comes back online, and replugging it prompts is to do so.

    I've had things that did this in the past, mainly my 3D Vision infrared emitter.
    Fortunately it is right under my monitor and has a plug on its back side.

    Mike
     
  8. wilmer007

    wilmer007 New Member

    Joined:
    Mar 10, 2015
    Messages:
    4
    Likes Received:
    0
    well i was able to put the computer into hibernate and when i turn it back on it stays fine so i have to rely on hibernate as a band aid.

    hopefully windows 10 doesn't give this headache anymore.
     
  9. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,051
    Likes Received:
    302
    Hi

    My problem with the emitter went away with Windows 10, so keep your fingers crossed.

    Mike
     

Share This Page

Loading...