Insider Preview No Way To Change Network Settings From Public To Private On Windows 10.

Discussion in 'Windows 10 Help and Support' started by Andrea Borman, Nov 27, 2014.

  1. Andrea Borman

    Andrea Borman Honorable Member

    Joined:
    Oct 10, 2010
    Messages:
    1,167
    Likes Received:
    7
    I have installed Windows 10 Tech Preview 32 bit Build 9879. Yet I have found there is no way at all to change the network settings from Public Network to Private. On Windows 8.1 you could do this by going to PC Settings and clicking on the network but this does not work at all in Windows 10 . I have also tried tuning on network discovery in Network and sharing center but as you can see in my screenshots this does not work.So has this been removed n Windows 10?

    NTWork1 (640x375). NTwork2 (640x375).
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,784
    Likes Received:
    1,563
    Not too sure myself but it's probably worth sending the feedback in as they need to know if any bugs are found.
     
  3. Andrea Borman

    Andrea Borman Honorable Member

    Joined:
    Oct 10, 2010
    Messages:
    1,167
    Likes Received:
    7
    Well I have tried the method used in Windows 8.1 as in this video. But it doesn't work on Windows 10. So it maybe they have either removed or disabled this option in 10. Even when turn on network discovery my network is not visible on my other computer as it should be. And the setting is stuck at Public Network with no way to change it.

     
  4. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,784
    Likes Received:
    1,563
    Don't forget that this is beta software and some bits may work properly and some bits not. We've all (or at least most of us) have bugs to do with this build. This might be just one of them instead of a new policy or setting.
     
    Sonny likes this.
  5. Andrea Borman

    Andrea Borman Honorable Member

    Joined:
    Oct 10, 2010
    Messages:
    1,167
    Likes Received:
    7
    Well it could be that maybe there isn't any settings in Windows 10. In Windows XP there is no Private or Public network. If you don't want other computers to see your network or files you just turn off file sharing and network discovery. Maybe it's the same thing on Windows 10. If you turn on both the file sharing and network that should work but it doesn't. I don't know why that is. Another thing I don't like about Windows 10 is that Microsoft have removed the option to disable Windows Update which was in previous versions of Windows. As is in my Windows 7 so it seems that we have less control over our OS in Windows 10.

    Windows 7 Update-Never Check For Updates setting which is not in Windows 10.

    UpdateW7.
     
  6. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    When I installed, by default, I am on a private profile. ??
    I think this was an option I chose at the end of the installation, but cannot test that for the moment.
    I also recall that, in Windows 8, this was in some way connected with having a secure wireless or ethernet connection.

    Don't be too disturbed by the lack of some control features in this release. It is deliberate, as MS want a common base for examining feedback. There are several registry tweeks already running around, to change items in Windows Tech preview. Making these changes, and then sending feedback to MS, is, as you can see, not in their best interests to develop improvements




    . Capture.PNG
     
  7. Andrea Borman

    Andrea Borman Honorable Member

    Joined:
    Oct 10, 2010
    Messages:
    1,167
    Likes Received:
    7
    Well on Windows 8 you could change it by clicking on the WiFi icon. Then In 8.1 you had to go to PC Settings to change it as you saw in that video. But that does not work at all in Windows 10 and I cannot find any settings at all to change it. So I assume you cannot. I have also searched on Google but I have not been able to find anything on the web how to solve this problem.
     
  8. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    After examination, it does seem that so far, whether it says public or private, we are perhaps joined to bot by default. Possibly deliberate for the testing.
    But, whatever, I am, a said, on a private network by default and, fwiw, can access my Windows 10 test laptop from a windows 7 and a windows 8.1 Laptop in the house.
    added. I am curious. Any other users who can offer if they are on a private or public network??
     
  9. Andrea Borman

    Andrea Borman Honorable Member

    Joined:
    Oct 10, 2010
    Messages:
    1,167
    Likes Received:
    7
    I have finally solved the problem. The settings are there n Windows 10 but not as easy to find as in Windows 8.1. apparently you have to go to PC settings not ZPC settings.

    Click on manage networks.

    Then you have to disconnect from the network then reconnect to it.
    You will have to enter your WiFi password again to reconnect. Then where it asks "Do you want to find PC devices on this network-Select:
    Yes for Private network or
    No for Public Network.

    So what I did was select yes then as you can see my network has now been changed to Private network as you can see from my pictures. Though it seems silly that you have to jump through hoops just to change your network. We never had to do this on Windows 7 or 8.

    Change Network1 (640x375).
    Image 3.JPG Image4 (640x375). Change Network2 (640x375) (640x375).
     
  10. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    Well done, Andrea. I will take your word for it, as I am happy with my settings at the moment. That confirms my thought. It was something you could configure in the initial install. I, apparently, chose Private.
     
  11. Andrea Borman

    Andrea Borman Honorable Member

    Joined:
    Oct 10, 2010
    Messages:
    1,167
    Likes Received:
    7
    Yes it seems that when you first set up a network on Windows 10 you have to choose either public or private at the time of set up. But if you want to change say from Private to Public then you must disconnect from the network then connect to it again.

    It seems you cannot just change the settings as you can on Windows 7 and 8.1. I suppose Microsoft think that once you have chosen ether public or private network, you won't want to change it again. But when you connect you must select Yes for Private and No for public when it asks if you want to share your files during the set up.
     
  12. Shin

    Shin New Member

    Joined:
    Apr 12, 2015
    Messages:
    1
    Likes Received:
    0
    Hey Andrea, I have the same problem. Installed Windows 10 Preview, and saw that it is showing my network as Public. Tried various things that worked in Windows 8, like User Account Control Settings, and it still didn't work. Tried forgetting the network and re-connecting, and chose the 'Find devices on network' option. But, unfortunately it still is showing my network as Public. Anyone help?
     
  13. DaveChr

    DaveChr New Member

    Joined:
    Jun 7, 2015
    Messages:
    2
    Likes Received:
    0
    I think I just stumbled on how to change a public network to private in Windows 10 Preview.

    Open File Explorer and click Networks. I got a message along the top of File Explorer saying I was on a public network and to click to change the connection to a private network. I did and my connection is now a private network. :)
     
  14. DaveChr

    DaveChr New Member

    Joined:
    Jun 7, 2015
    Messages:
    2
    Likes Received:
    0
    I may have spoken too soon, sorry. When I rebooted the connection had become a public network again.

    Here are the steps that worked until reboot with more detail.
    - File Explorer
    - Click Networks in left pane
    - Message along top says network discovery and file sharing are turned off, click to turn on
    - Dialog with option to turn on network discovery and file sharing for all public networks or make the network I'm connected to a private network. Click the latter.
    - Connection becomes a private network, at least until reboot
     
  15. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Is your install currently matched to a Microsoft account?

    I did an install last night offline so I only had a local account. I tried some things, but it came back to Private after I logged onto my Microsoft account. I will keep an eye on it during the next new build install to see if I can confirm or dismiss this observed behavior.

    Edit: I had forgotten about a setting on the Network settings which turns on "Find Devices and Content". It would seem to be a network discovery setting, but seems to be independent from that setting and will change your system to Private.
     
    #15 Saltgrass, Jun 7, 2015
    Last edited: Jun 8, 2015
  16. Mark Brantner

    Mark Brantner New Member

    Joined:
    Aug 29, 2015
    Messages:
    5
    Likes Received:
    0
    There is a way to change your connection from Public Network to Private Network in Windows 10.
    On the Network and Sharing Center page, in the lower left-hand corner, find HomeGroup.
    Click it and either join an already-created HomeGroup in your location or create one.

    Once completed, you will be on a Private Network.
    Remember to write down the password somewhere and keep it safe.
    There is supposedly an option to change it as well after creation.

    Hope this helps!

    Mark
     
  17. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Mark, did you not read my post immediately in front of yours? Left click Network Icon, select Network Settings. From there click on the connection and set "Find Devices and Content" to ON.
     
    #17 Saltgrass, Aug 29, 2015
    Last edited: Aug 29, 2015
  18. Mark Brantner

    Mark Brantner New Member

    Joined:
    Aug 29, 2015
    Messages:
    5
    Likes Received:
    0
    I'm not sure if my Windows 10 Pro works the same as your version of Windows.
    I right-click the Network Icon, I get a choice of 'Troubleshoot Problems' and 'Open Network and Sharing Center.'
    There is no 'Network Settings' option of choice as you state.
    There is also no 'Find Devices and Content' setting to switch on.

    I figured I might be missing something, so I looked up your procedure on the Microsoft website and it agrees with you...
    except it's not for Windows 10, it's only for Windows 8.1 and Windows RT 8.1

    Otherwise, I would have been most happy to use your procedure.

    ~Mark
     
  19. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Try left clicking, it might work better. I get so used to saying right clicking, I forget there is actually a left click.

    The Network option is very dim on the lower left of the popup panel.
     
  20. Mark Brantner

    Mark Brantner New Member

    Joined:
    Aug 29, 2015
    Messages:
    5
    Likes Received:
    0
    Ah, There's a Network Settings :)
    It brings up Network & Internet which has on the left column:
    Wi-Fi
    Data Usage
    Dial-Up
    Ethernet
    Proxy

    On the main part of the page:
    A list of WIRELESS CONNECTION SETTINGs

    Advance Options
    Manage Wi-Fi Settings

    RELATED SETTINGS
    Change adapter options
    Change advanced sharing options
    Network and Sharing Center
    HomeGroup
    Internet Options
    Windows Firewall

    I do not see the next step you suggested.
    Perhaps it is a matter of what one has upgraded from?
    I upgraded from Win7, perhaps you upgraded from Win8?

    ~Mark
     

Share This Page

Loading...