Only 50% of the CPU with Windows 7

#1
Hi I recently installed windows 7 64x on my computer after having windows Vista 64x for 2 years. However there is one problem, It seems i only use about 50 % of my CPU capacity.

I discovered the problem when I tried playing Crysis, Which I never have had any problem playing with Vista. The game was extremely slow and it was then I saw that the CPU usage only was at 50 % max.

So I was wondering if maybe I should install something to increase the compatibility between the hardware and windows 7 perhaps.
So if anyone have any idea of what I might need to do, Please Help!
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
Was this upgrade done over Vista or did you do a custom install?

What video card and which driver are you using?

It might be good to just go through your computer specs.
 


zvit

Honorable Member
#3
Here's a thread I found about your problem. Helped most people.



http://andrewblock.net/?p=445

I've seen a few threads on the Internet about this, so I know I'm not the only loser trying to play Crysis on my shiny new OS. Thankfully, it's really easy to fix—here's what to do:

  • Go to the folder where the 64-bit executable is for Crysis (Crysis.exe). Mine was located in: C:\Program Files (x86)\Electronic Arts\Crytek\Crysis\Bin64
  • Right-click on Crysis.exe and click the "Compatibility" tab.
  • Check the box that says "Run this program in compatibility mode for:" and then choose "Windows Vista (Service Pack 2).
  • Click OK, and run the game. This got it working for me.
 


#4
Was this upgrade done over Vista or did you do a custom install?

What video card and which driver are you using?

It might be good to just go through your computer specs.
It was a clean install

My video card is NVIDIA GeForce 9600 GT and I updated with this driver yesterday:
NVIDIA DRIVERS 257.21 WHQL


Here's a thread I found about your problem. Helped most people.
Crysis 64-bit and Windows 7 | Welcome to Andrewblock.net
Actually I'm already using that, However that does not fix the CPU problem.
It is not just bound to one game the same thing happened while I was trying to play the starcraft II beta.
 


#5
Type msconfig in the start menu then hit enter. Go to the boot tab. Click advanced options.

Make sure the number of processors box is not checked. If it is, remove the check box and save. Reboot.
 


#6
Type msconfig in the start menu then hit enter. Go to the boot tab. Click advanced options.

Make sure the number of processors box is not checked. If it is, remove the check box and save. Reboot.
I tried that but it didn't fix the problem :/
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#7
Have you tried running the 32 bit version of Crysis?

When I was running a GTX 260, in order to get better performance I had to go backward with the Nividia drivers. I do not remember exactly which one, but it seems it was 196.83. Since I no longer have that card in this computer, I cannot check.

It looks like I am running around 20% CPU with the GTX 480, but it seems Crysis is not good at using multiple processors. I am running in High resolution since the Extra setting is tough even for this 480.

If you upgraded over Vista, there is a possibility some driver or other type of file could be causing problems, which is one reason most people suggest clean installs. You might also want to reinstall Crysis and make sure to add the patches.
 


zvit

Honorable Member
#8
Yes, an older Nvidia driver has helped me in the past. I have all the NVIDIA drivers starting from 178.24 but mine is for GeForce 9800 GT. If you have trouble finding older drivers, tell me and I'll find them for you.
 


#9
Yes, an older Nvidia driver has helped me in the past. I have all the NVIDIA drivers starting from 178.24 but mine is for GeForce 9800 GT. If you have trouble finding older drivers, tell me and I'll find them for you.
Yeah I was wondering how to find old drivers, so if you could help me with that it would be uber awesome
 


Captain Jack

Extraordinary Member
#10
Hello,

Few questions before getting into the troubleshooting part !!

Is it only happening to that Game alone ?? Try to open few application try to Over load you PC and see if the CPU usage goes to 100 % seems like something is wrong with OS itself. What is the size of your Page File ? Go to your Task Manager and under Processes Tab how many processes are running ?? What is the security software are you using ??

Hope this helps,
Captain
 


#11
Hello,

Few questions before getting into the troubleshooting part !!

Is it only happening to that Game alone ?? Try to open few application try to Over load you PC and see if the CPU usage goes to 100 % seems like something is wrong with OS itself. What is the size of your Page File ? Go to your Task Manager and under Processes Tab how many processes are running ?? What is the security software are you using ??

Hope this helps,
Captain
No it happens to other games as well. Hmm when I tried to over load my PC the CPU usage when past 50 % to alot more then I had before, so guess the problem is not with the processor :p

"Page File"?

I have about 40 processes running, and for the time being I have no security software :p
 


Captain Jack

Extraordinary Member
#12
Hello,

That's a good new !! Ok reboot the System in selective startup and see if that makes any difference Run Selective Startup using System Configuration as suggested before reinstall Display drivers would be a good idea.

Page File is Virtual Memory that we set to improve the performance of the PC like an additional RAM.

Good Luck,
Captain
 


#13
Ok I tried to use an old driver for my graphics card, however it didn't make any difference.
The size of my Page File is 4096 mb.

Maybe I need to update my motherboard...

Seriously I don't get this, I made a clean install of W7. Ok what kind of updates do I need? :/
 


#14
See if there is a bios update for your current motherboard. If there is, install it. You can check on the manufacturer's website for it. Use CPU-Z to find out which motherboard you have, if you don't know.

Also, here is something that can be really helpful to us to solve the issue. Type msinfo32 in the start menu then hit enter. File | save on the screen that opens. Then zip the saved file and attach it to a post using the paperclip above where you type, in advanced mode reply.
 


Last edited:
#16
I suggest you uninstall Daemon Tools Lite. It is one of the worst causes of bsod and other problems under Windows 7. You can use the special uninstaller/installer here to remove sptd.sys from the system after, which is very important to do:

DuplexSecure - Downloads

I suggest PowerIso as an alternative for drive emulation, which always remains free:

PowerISO - Create, Edit, Compress, Encrypt, Split, Mount, Extract ISO file, ISO/BIN converter, Virtual Drive

------------

If you don't have 3D glasses, type services.msc in the start menu then hit enter. Use this screen to disable and stop the NVIDIA Stereoscopic 3D Driver service.

----------

Everything else looks alright. It could actually be an issue with the game itself, especially if there have been any workarounds used to make it start, if you know what I mean. (Not saying this is the case, just giving example of a possibility for why.)

----------

As for the latest bios, install this one: P5N-D BIOS 1401, from July 1, 2010. It's available in the download section of your link.

You currently only have 0304 from February 1, 2008.
 


#17
Ok no more daemon tools and Stereoscopic 3D Driver service.

I installed the bios you said, but the problem still exist.
The problem is with all games which demands a lot of power...
for example I can't play my precious Starcraft 2 beta whatsoever at the moment :(
 


#18
I know what's going on with your machine, since I am having a very similar issue with only a game or two here myself. Others all work well and sometimes, these games having problems mysetriously decide to work well for me.

Two things for you to try as a test:

1) Before starting the game, use the task manager and system tray near the clock to close absolutely everything not needed for Windows to stay up. Get it down to the bare minimum. No gadgets, no 3rd party software like Rocketdock or Display Fusion....nothing....Then try starting the game and see how it goes.

2) Try disabling Aero while the game is going, as a test. To do so, right click the shortcut for the game. Choose properties, then compatibility tab. Check the box for Disable Desktop Composition. Save it and then try starting the game.
 


zvit

Honorable Member
#19
Ok I tried to use an old driver for my graphics card, however it didn't make any difference.
/
I just got back to my computer and assume you had already found and tried an older driver so I suggest you keep up with the other suggestions.
 


#20
I know what's going on with your machine, since I am having a very similar issue with only a game or two here myself. Others all work well and sometimes, these games having problems mysetriously decide to work well for me.

Two things for you to try as a test:

1) Before starting the game, use the task manager and system tray near the clock to close absolutely everything not needed for Windows to stay up. Get it down to the bare minimum. No gadgets, no 3rd party software like Rocketdock or Display Fusion....nothing....Then try starting the game and see how it goes.

2) Try disabling Aero while the game is going, as a test. To do so, right click the shortcut for the game. Choose properties, then compatibility tab. Check the box for Disable Desktop Composition. Save it and then try starting the game.
Tried both things, but the result was the same as before

I just got back to my computer and assume you had already found and tried an older driver so I suggest you keep up with the other suggestions.
I tried the 196.21 driver dunno how that one matters though.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.