Problems with DVD drive (not similar)

Discussion in 'Windows 7 Hardware' started by Dragostas, Feb 11, 2009.

  1. Dragostas

    Dragostas New Member

    Joined:
    Feb 11, 2009
    Messages:
    8
    Likes Received:
    0
    I have a philips spd 2413 DVD/CD drive burner
    This device shows in windows explorer and shows no problem in the device manager
    Unfortunatly the drive does not respond to auto play disks
    I also cannot explore the drive in windows explorer
    When trying to access the drive it tells me to insert a disk and then a safely remove hardware prompt come up as it ejects the CD.
    Any ideas?
     
  2. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Try going to Control Panel > Default Programs an see if there is an association for the .cda extension.

    Or if there is a Change AutoPlay settings link.

    I can't check this for sure as my Windows 7 machine is down at the time

    You should be able to play CD's by using Windows Media Player.
     
  3. Dragostas

    Dragostas New Member

    Joined:
    Feb 11, 2009
    Messages:
    8
    Likes Received:
    0
    Anyone have any other ideas this one didn't help
     
  4. Hrulik

    Hrulik New Member

    Joined:
    Jan 17, 2009
    Messages:
    6
    Likes Received:
    0
    I have same issue, cant browse cd/dvd by explorer, but can by total commander,
    elso cant execute any .exe files from dvd drive, need copy to hdd first. Look like somesing wrong with permitions...
    any one have solution?
     
  5. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Try going to Control Panel > Hardware and Sound and click on AutoPlay.

    What program is listed under Audio CD?
     
  6. Hrulik

    Hrulik New Member

    Joined:
    Jan 17, 2009
    Messages:
    6
    Likes Received:
    0
    I tryed any variants of autoplay, it not help. Defenetly it is permitions problem. I have 3 user accounts on this machine. And only in one account I can browse dvd drive and run programms from dvd. I tryed compare this accounts. All of them is members Administrators group.
    More ideas?
     
  7. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    In the AutoPlay settings there is a small checkbox at the top stating Use AutoPlay for all media a nd devices. Is that checked?

    I doubt it's permissions as I have just created a standard user account and put in a Autorun DVD. This DVD was from magazine that has it's own interface to browse the DVD. So, it gave me 2 choices:

    1. Run start_here.exe
    2 Open folder to view files
    .
    I then opened the AutoPlay Control Panel applet, and there were no program at all listed in any section
     
  8. Dragostas

    Dragostas New Member

    Joined:
    Feb 11, 2009
    Messages:
    8
    Likes Received:
    0
    Auto Play features are correctly set up
    I don't think you understand my situation fully
    I cannot explore ANY DVD/CD disc through windows explorer.... When I click on the drive to explore the DVD drive it ejects the disc and tells me I am able to safely remove hardware. Upon checking on my safely remove hardware icon in control panel; it shows no settings involved with the drive and, the drive is not listed.
    As for permissions I only have one administrative account so I do not think that is involved.
     
  9. kevin from Chi-town

    Joined:
    Jan 11, 2009
    Messages:
    714
    Likes Received:
    8
    KISS...i had an unresponsive dvd from sony...turns out in my haste I had connected the power to a molex supply that was already being used. Once I moved the dvd power supply it worked fine.....just a thought
     
  10. Dragostas

    Dragostas New Member

    Joined:
    Feb 11, 2009
    Messages:
    8
    Likes Received:
    0
    Anyone got anything on this I am stuck
     
  11. ankdoz

    ankdoz New Member

    Joined:
    May 12, 2009
    Messages:
    8
    Likes Received:
    0
    same problem

    i have a LG GSA H20N ATA DVD RW. im using windows 7 RC. and it worked fine for some time after installing the x64 OS, but suddenly from now the CD/DVD is not being read. Whenever i put a CD/DVD into the drive, the light blinks for sometime and goes blank. When i double click the drive in Comptuter, it says insert disk into the drive and opens the tray. The drive is being detected in the BIOS.

    Anyone with solutions?

    Oz
     

Share This Page

Loading...