Remove Write Protection

Discussion in 'Windows 7 Help and Support' started by Jed Bridges, Nov 15, 2010.

  1. Jed Bridges

    Jed Bridges New Member

    Joined:
    Nov 14, 2010
    Messages:
    4
    Likes Received:
    0
    Hi all,

    I'm having a problem that seems to be shared by many other users based on the number of forum threads i've come accross related to this topic. I'll describe it in some detail to avoid the usual advice which hasn't worked so far so please bear with me.

    I am unable to move files onto external devices. Windows gives me a message to the effect "the drive is write-protected. Remove write protection or try another device" I've seen a lot of advice directed at fixing USBs but I think my computer is the problem because more than one device is affected.(both external hard drive and USB stick).

    I just recently had my hard drive fail. I've had it replaced under warranty but it seems this may have been this trigger. The replacement hard drive is of a lower speed as they had run out of stock so I'll be replacing it yet again in a few days when the stock arrives. I'm hoping this may negate the problem but I'd like to back up a few more files in the meantime.

    The most effective fixes for people in this situation seem to be changing the registry through the following path:
    HKEY_LOCAL_MACHINE>SYSTEM>CurrentControlSet>Control>StorageDeviceProperties
    then changing the write protect file so the data value is set to 0.
    Initially the folder 'StorageDeviceProperties' did not exist so i created the folder and the key within as per instructions from numerous forums. I also checked the ControlSet001 and 002. All were set correctly with no effect on the write protection of the devices.

    Another effective solution for others was using the diskpart application within the 'cmd' function to select the volume of the drive and clear the readonly status. This also proved inneffective.

    I've tried formatting the USB as a last resort, the write protection also prevents this. And as of this morning I'm unable to access the USB at all. It asks to be formatted before use, which doesn't work presumably because the write protection is still in place.

    So my question is if there are any other known fixes to this problem which seems to be common in windows7 as well as in previous OS. If I do a clean install of windows as will happen when I replace the hard drive again, should the issue be fixed?

    Thanks, Jed
     
  2. Joe S

    Joe S Excellent Member

    Joined:
    Jan 12, 2009
    Messages:
    3,785
    Likes Received:
    113
    Is this external drive a WD with Smartware by chance?
    Joe
     
  3. Jed Bridges

    Jed Bridges New Member

    Joined:
    Nov 14, 2010
    Messages:
    4
    Likes Received:
    0
    No the USB is a Shintaro, and the external hard drive is a Seagate
     
  4. Mike Duckwall

    Mike Duckwall New Member

    Joined:
    Feb 29, 2012
    Messages:
    2
    Likes Received:
    0
    **HELP!!!**Ok, after many years of being virus free, I think I've been got. I have the same problem as above. I have been working day and night for about a week to resolve the problem...whatever the problem may be. If anyone is successful in finding the source and/or cure for removing the write protection on USB's, please post here. USB Thumb Drives that I have used without any problems are all of a sudden "Write Protected"! Grrrrr & Ugggg! :cry_smile:
     

Share This Page

Loading...