Server 2019 Storage Migration Services error during Validate Devices - Fail: Error HRESULT E_FAIL has been returned from a call to a COM component.


New Member
Not sure if this is the right place to ask this question.

I am using Storage migration services to move from a 2012 R2 server to a 2016 server. I do have a 2019 server running the migration services. All are on the domain. The current 2012R2 is a DC currently but will be decommissioned soon. I can inventory the 2012 R2 server no problem. Then when I get to the Validate Devices and try to Validate i am receiving an error under the second one down.

We can transfer data from the source computer at maximum speed. This might fail when required software updates are not installed on the source.

Fail: Error HRESULT E_FAIL has been returned from a call to a COM component.

I cannot find anything relating to this error and SMS online. I tested trying to move some files to the 2019 server that I am running SMS on and get the same error so i would assume it points to the 2012R2 server. I have used SMS a handful of times and it has always worked great. Anyone know what the error points too?

I do get an error in SMS under Storage Migration - Admin that it failed to register the proxy on the 2016 server i am trying to move to. Not sure how to register the proxy or what that error means either.

Firewalls are off and AV was turned off for testing. Using a DA account that does have permissions. all servers are fully patched, and SMS is running the latest version.

Under Adjust Settings i do have "Don't transfer users and groups checked as well.