Something weird is going on..

#1
I don't know if its my windows computer or the Internet. But here's what is going on: My computer has been slower than it usually is, and the Internet is constantly loosing connection, it first happened to my windows computer, then it started happening to my laptop. Can someone help me?? I don't know what to do!
 


#2
Anyone? I need help!
 


#3
First thing to check, is scan the system for any malware, spyware and virus's and other nasty's that might be hiding on one's system. Then make sure windows is update with the latest MS updates, then update any outdated drivers. Then defrag hard drive and reboot system and check for issue.
 


#4
First thing to check, is scan the system for any malware, spyware and virus's and other nasty's that might be hiding on one's system. Then make sure windows is update with the latest MS updates, then update any outdated drivers. Then defrag hard drive and reboot system and check for issue.
Ok, thanks.
 


#5
First thing to check, is scan the system for any malware, spyware and virus's and other nasty's that might be hiding on one's system. Then make sure windows is update with the latest MS updates, then update any outdated drivers. Then defrag hard drive and reboot system and check for issue.
My McAfee isn't working...:-c
 


Mike

Windows Forum Admin
Staff member
Premium Supporter
#6
First run Malwarebytes Antimalware. Sounds like there is a major problem with your system if the anti-virus has choked up.
 


Last edited:
#7
Last edited by a moderator:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.