Insider Preview Still having sound issues...

Discussion in 'Windows 10 Help and Support' started by MikeHawthorne, Jan 30, 2015.

  1. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,052
    Likes Received:
    303
    Hi

    Just when I thought I had everything fixed Windows forced me to update my sound drivers again.
    I couldn't find any way to stop it, it showed that what it was updating was my Sound Blaster drivers.

    In the previous build I could tell it not to update those drivers but I don't see that option In this version.

    I tried restoring the sound the way I did before, by uninstalling my sound card in Device Manager and then rebooting.

    Only this time it didn't recognise my sound card and reinstall it.

    When I tried to run the Creative software install it said it didn't detect the sound card either.

    I used my system Image and restore my computer to before it updated.

    Now everything is working again but I don't want to have to keep doing this.

    I don't know why my SB Audigy PCIe sound card won't work if the drivers are updated but its been this way since I first had this issue when updating to Windows 8.1.

    It does the same thing if I update the drivers directly from Creative Labs.

    My last option is to get a non Creative sound card and maybe that will stop the problems.

    If anyone has any idea how I can stop Windows 10 from forcing me to update let me know, it really seems that Windows should let you run the drivers that you want for your devices.

    I know I'm not the only one with this problem, when I installed W8.1 I found a bunch of people complaining about the same thing.

    Mike
     
  2. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    They seem to have missed out the option in the "settings" ,Mike. But if you go the legacy path, ie.. open the old Control Panel - System - Advanced System settings - Hardware Tab. There you will find the option to allow you to choose what to do with driver software.
     
  3. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,052
    Likes Received:
    303
    Hi Dave.

    Ok, I've done that, we'll just have to wait and see what happens now.
    If I could just get past this problem everything else is working fine.

    [​IMG]

    I finally found that my Power Plan which tells my computer to go to sleep after 20 minutes of inactivity doesn't seem to do anything, but I found another place, "Tell your computer when to sleep" or something like that, that does the same thing using one of the standard plans.

    We'll see if that works.

    Mike
     
    #3 MikeHawthorne, Jan 31, 2015
    Last edited: Jan 31, 2015

Share This Page

Loading...