Strange Windows 7 problem only crashes when install drivers.

Discussion in 'Windows 7 Help and Support' started by Steven Woodhall, Sep 3, 2012.

  1. Steven Woodhall

    Steven Woodhall New Member

    Joined:
    Sep 3, 2012
    Messages:
    2
    Likes Received:
    0
    One day I turned on my laptop and on startup the mouse was really slow and laggy then would crash, I tried it in safe mode and was no problem so I went ahead with a clean install of windows 7.

    After the install everything was fine and could restart with no problem but after I installed the graphics driver the same problem returned. This seem really weird as the driver was working fine before.

    The laptop I'm talking about is an acer aspire 5050 series and the model is 5052.
     
  2. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,046
    Likes Received:
    300
    Hi

    Are you sure you are installing the correct drivers?

    Download

    Check out the driver listed on their site.

    If that doesn't work...

    Then uninstall the video device in Device Manager and let the computer reboot and let Windows reconfigure and reinstall the video on it's own.

    If neither of these work come back and let us know.

    Mike
     
  3. Jarbas Santos

    Jarbas Santos New Member

    Joined:
    Sep 3, 2012
    Messages:
    4
    Likes Received:
    0
    Maybe your drive is not correct.
     

Share This Page

Loading...