Stuck in 640x480 while driver software is enabled

#1
I am no longer at the computer with the problem and likely won't be for a while. If you have better things to do, don't reply for the time being because I'm physically unable to troubleshoot anything on the problematic PC. (It's on the other side of the state.) I may post here again one day if the need arises but until then, there's nothing I can do. Thank you to those of you who have tried to help. =]
-------------------------------------------------------------------------------------------------------
I've been using my Aunt's computer while I've been staying at her house, and for some reason it's acting very strange. Whenever I enable the driver software for the graphics card (according to the device manager it's an "AMD Radeon HD 6410D") the computer only displays in 640x480 resolution.
only640x480resolutionsettings.png List all modes.png

However, when I disable the driver software the computer displays anything from 800x600 to 1600x1200 but I can't do anything that requires the use of a graphics card whether it's playing Steam games or whatever else.
disabled.jpg Steam games don't work.jpg
Ordinarily I would expect the driver software to improve the displays, so naturally I've gone online several times and tried downloading and installing updates for this computer's driver as well as installing up to date versions of directX but to no avail. I've even tried going into the settings of the driver itself but the display settings only list 640x480 there as well.
only640x480driversoftware.png

I've tried looking around a bit but I can't seem to find anyone that's had the same problem let alone how they fixed it.
Any help would be much appreciated.
 


Last edited:

patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#2
Did you go to the Radeon site for the driver download? Also try removing the device from device manager and letting Windows detect and reinstall on boot.
 


#3
I got the driver software fro right here: AMD Catalyst? Display Driver for Windows Vista/Windows 7 64-bit
the first one on the list.

I've actually tried uninstalling and allowing it to detect the software multiple times but it's never helped. I've been thinking it's a possibility that I may need to run the software that I downloaded from the above link after uninstalling, but every time I uninstall and then restart, windows automatically downloads and re-installs the driver software before I can stop it. Could that possibly be a problem?
 


Last edited:

GeneralHiningII

Honorable Member
#4
Disable automatic downloads through Windows Update -
Start > [right-click] Computer > Properties
Left Bar: See Also > Windows Update
Left Bar: Change Settings
Select: [Check for updates but let me choose whether to download and install them]


Also try following pat's instructions (disabling driver software through Device Manager and rebooting your computer) -
In fact, I might add a suggestion to that:
Install Driver Sweeper.
Reboot your computer and enter Safe Mode (Repeatedly key F8 [before the Windows Logo] and select Bootup Option: Safe Mode).
In Safe Mode, Open Device Manager and uninstall your Graphics Card Driver.
Then run Driver Sweeper (in Safe Mode) and select: ATI - Display.
Select Analyze, then Select Clean.
Reboot when prompted.

NOW -
Install your ATI Driver from the website

Hope I helped
 


#5
I constantly have the video driver disabled in the device manager unless I'm trying to fix the problem so disabling it and restarting would be redundant. If you mean uninstalling in the device manager and then restarting and allowing windows to detect and reinstall, as I've said, I've done that multiple times and it has never helped.
Thank you for the instructions on changing the options on automatic updates though. Also, I'll try your suggestion regarding safe mode and driver sweeper. I'll report back when I'm done on whether it worked or not.
 


bassfisher6522

Essential Member
#6
Need your make and model of PC? Need your system specs of said PC?

So far what I've been able to find out is that it's a CPU/GPU in one CPU chip...the chip line is called an APU which has an intergraded GPU in the CPU it self. A combo deal if you will. Not to my liking at all. I can't seem to find any thing else out on it.

Newegg.com - AMD A4-3400 Llano 2.7GHz Socket FM1 65W Dual-Core Desktop APU (CPU + GPU) with DirectX 11 Graphic AMD Radeon HD 6410D AD3400OJHXBOX
 


#7
Need your make and model of PC? Need your system specs of said PC?

So far what I've been able to find out is that it's a CPU/GPU in one CPU chip...the chip line is called an APU which has an intergraded GPU in the CPU it self. A combo deal if you will. Not to my liking at all. I can't seem to find any thing else out on it.

Newegg.com - AMD A4-3400 Llano 2.7GHz Socket FM1 65W Dual-Core Desktop APU (CPU + GPU) with DirectX 11 Graphic AMD Radeon HD 6410D AD3400OJHXBOX
Computer specs.png
Does this cover your inquiry?
 


#9
Disable automatic downloads through Windows Update -
Start > [right-click] Computer > Properties
Left Bar: See Also > Windows Update
Left Bar: Change Settings
Select: [Check for updates but let me choose whether to download and install them]


Also try following pat's instructions (disabling driver software through Device Manager and rebooting your computer) -
In fact, I might add a suggestion to that:
Install Driver Sweeper.
Reboot your computer and enter Safe Mode (Repeatedly key F8 [before the Windows Logo] and select Bootup Option: Safe Mode).
In Safe Mode, Open Device Manager and uninstall your Graphics Card Driver.
Then run Driver Sweeper (in Safe Mode) and select: ATI - Display.
Select Analyze, then Select Clean.
Reboot when prompted.

NOW -
Install your ATI Driver from the website

Hope I helped
It says not "ATI Display" but "AMD Display" if that makes any sort of difference. I'll try what you said with that one though I suppose.
 


#11
Downloaded and ran the chipset driver update. Restarted the computer, enabled the driver software and then restarted again. It still will only display in 640x480. =/
 


#12
Disable automatic downloads through Windows Update -
Start > [right-click] Computer > Properties
Left Bar: See Also > Windows Update
Left Bar: Change Settings
Select: [Check for updates but let me choose whether to download and install them]


Also try following pat's instructions (disabling driver software through Device Manager and rebooting your computer) -
In fact, I might add a suggestion to that:
Install Driver Sweeper.
Reboot your computer and enter Safe Mode (Repeatedly key F8 [before the Windows Logo] and select Bootup Option: Safe Mode).
In Safe Mode, Open Device Manager and uninstall your Graphics Card Driver.
Then run Driver Sweeper (in Safe Mode) and select: ATI - Display.
Select Analyze, then Select Clean.
Reboot when prompted.

NOW -
Install your ATI Driver from the website

Hope I helped
Tried this, and actually tried it with a few variations as well like in conjunction with the chipset software shown to me by bassfisher. It still only displays in 640x480. >.<

(Also I apologize if posting multiple times in a row is against the rules on this forum. It's against the rules in many of the sites I've visited but I didn't see it in the code of conduct when I signed up. If it is against the rules please let me know.)
 


GeneralHiningII

Honorable Member
#13
IT's alright, not like many people would care.

AMD and ATI Display drivers are the same, ATI is now owned by AMD.

To be honest, I really don't like the card you're using (CPU and GPU on one card) - maybe it's just me, but I prefer to have them separate. This may or may not be the problem since
A - I have never worked with a problem like yours
B - I'm not that great with AMD/ATI devices (hence the profile picture and sig pic)
 


#14
Well thanks for the help anyway. ^_^

I'm not at my aunt's house anymore and I'm back on the computer that I regularly use so I guess I'm fine now in the technological aspect of things. Thanks again!
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#15
A couple of things. Your one attachment says you need to refresh the WEI. Have you done that, or does it reoccur because of the disabled device?

On your resolution attachment, it says the Display is a device connected to a DVI. I have not seen that before, normally it will give the name of your display, but your system may be a little older and not capable. I do not know much about ATI video cards, but have you checked the type of DVI cable and the type of connectors it is being connected to?

Since I can't find anything about your system, any chance you have the DVI cable connected to a motherboard video output instead of the Video Card? Anything in the bios about video output?
 


#16
I did try to refresh the WEI... I can't remember what it did but it didn't end up working.

I'm not actually at this computer anymore and won't be for a while but if I were and if I do take a look at this PC again I'll be sure and take a look at the cable and connectors. If I remember correctly, "Display Device on DVI" was the only option available but I'm not positive. Thanks for your input. I've put something on the front of the thread explaining that I'm away from the PC now. Not much point to trying to get help when there's nothing I can do about it. ^_^;
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top