Time resetting and internet disconnecting every few hours

#1
Hi!

Ive been struggling with these problems for a really logn while. So the first problem is that my my windows' time resets every hour or so. The clock keeps looping a hour or two after i manually update it from the time server. I have tried other time servers than the windows' time server, but with no luck. And the only way to keep the clock up to date is to go manually update it again. I dont know if the internet disconnecting and clock resetting have some connection one way or the other. I have googled this and other people have been having the same issue, usually fixed with fiddling with the windows time service, but i couldnt fix it with that.

The second problem is the internet disconnecting every few hours. Im currently using wifi, trough an USB adapter, but i have tried lan cable also. Normally in wifi it takes just few seconds disconnecting and connecting back to the router to get the connection back. If i used lan cable, it sometimes took several minutes. I used an ethernet card with the cable.

These problems are really starting to annoy me so i appreciate any help you could give! :)

Im running a Windows 7 64bit
 


bochane

Honorable Member
#2
It is a known fact that if the battery on the mainboard of your computer is flat, your clock gets inaccurate.
Please check it or have it checked first.
 


Last edited:
#3
I changed the battery yesterday. The clock did not reset nor did the internet connection fail for the rest of the day (maybe 5 or 6 hours). But today when i started my computer, the clock was just what it was when i shut it down.
 


bochane

Honorable Member
#4
How are date/time settings now?
 


#5
How are date/time settings now?
well i actually fixed this (not really fixed but just avoided the problem) by scheduling a .bat file that syncs the time to run on startup. The new battery helped so that the clock doesnt get out of sync when the computer is runing but weirdly doesnt still keep the time up to date if the pc is turned off. And the internet hasnt been disconnecting at all with the new battery... so guess its ok now. Thanks for your help :)
 


bochane

Honorable Member
#6
There must be more wrong. That battery should be sufficient for being switched off for years.

Have you gone into bios and loaded the optimized defaults back in? That would be a possibility. But if you happy with this situation leave it.

Henk
 


#7
There must be more wrong. That battery should be sufficient for being switched off for years.

Have you gone into bios and loaded the optimized defaults back in? That would be a possibility. But if you happy with this situation leave it.

Henk
What do you mean by optimized defaults? And actually this solution didnt work after all, because the command i used cant sync more than a few minutes.. i didnt know about that yesterday because i was testing with only a few minutes.
 


bochane

Honorable Member
#8
OK
To get in BIOS, you press Esc or F2 (or some other key, I don't know your PC and it differs from brand to brand - you find it in the manual of your PC) shortly after power on when the splash screen of the manufacturer appears on the screen.

There are all kind of settings your PC needs to function, i.e. disks you are using, how much and which memory.
One of the options you find in BIOS, is reloading a set with optimized and fail save parameter values for your PC. Without battery or with a bad battery one of options in BIOS may have flipped over.
Reloading the optimized set and using them makes sure that you are using the correct values.

Hope it helps, Henk
 


#9
OK
To get in BIOS, you press Esc or F2 (or some other key, I don't know your PC and it differs from brand to brand - you find it in the manual of your PC) shortly after power on when the splash screen of the manufacturer appears on the screen.

There are all kind of settings your PC needs to function, i.e. disks you are using, how much and which memory.
One of the options you find in BIOS, is reloading a set with optimized and fail save parameter values for your PC. Without battery or with a bad battery one of options in BIOS may have flipped over.
Reloading the optimized set and using them makes sure that you are using the correct values.

Hope it helps, Henk
Nope, clock still not up to date when i boot up.
 


bochane

Honorable Member
#10
Sorry but I am out of options now.

Anybody else?
 


#11
One thing I have noticed is that the windows time service doesnt start automatically on boot up. But it stays on if i manyally start it. I have tried to fiddle with it before, but havent really got it to work.
 


bochane

Honorable Member
#12
Could you check the following?

Go back into BIOS. Normally you will find under tab Main -if not look through all settings until you find it- the system the system Date and Time and it should run and you should be able to adjust it.

Is that alright?
 


#13
Could you check the following?

Go back into BIOS. Normally you will find under tab Main -if not look through all settings until you find it- the system the system Date and Time and it should run and you should be able to adjust it.

Is that alright?
Yep, i can adjust it.
 


bochane

Honorable Member
#14
Than I don't understand why Windows don't want accept that time at start-up.
It may be some registry setting, I just don't know

Anybody?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top