Windows 7 WarCraft 3 puts monitor to sleep...

Discussion in 'Windows Games' started by MikeAlex, Mar 8, 2009.

  1. MikeAlex

    MikeAlex New Member

    Joined:
    Mar 8, 2009
    Messages:
    16
    Likes Received:
    0
    Yep... for some reason every time I go to play WarCraft III: Reign of Chaos it goes into sleep mode, the only way to get back to my desktop is to literally Alt+Ctrl+Del then turn my monitor off and back on again (shaking the mouse or hitting keys doesn't do anything). It plays the intro movie then does this as soon as the menu system tries to load. I've reinstalled the game and tried running it under other compatability modes, nothing. Disabling Desktop Composition also doesn't do anything, I heard this worked with a similar problem for someone else. But it works fine running it under my dual-booted Vista... any ideas what I might be doing wrong?

    Monitor: HP w2207h
    I've also downloaded the Windows 7 drivers from the official website... NVIDIA GeForce 8500 GT, and running DirectX 10.

    (all other games work fine, only WCIII is doing this.)
     
    #1 MikeAlex, Mar 8, 2009
    Last edited: Mar 8, 2009
  2. ChampDotA

    ChampDotA New Member

    Joined:
    Mar 9, 2009
    Messages:
    4
    Likes Received:
    0
    DirectX 10 I think is the problem. Windows 7 has 11 installed on it to begin with, maybe try to remove DirectX 10 and do a windows update. Once you did that, go to Command Prompt and type in "dxdiag" without the quotes and see what version you have.
     
  3. MikeAlex

    MikeAlex New Member

    Joined:
    Mar 8, 2009
    Messages:
    16
    Likes Received:
    0
    Alright, I ran the DxDiag and here's the stats I'm running with DirectX 11.

    Card name: NVIDIA GeForce 8500 GT (Prerelease - WDDM 1.1)
    Chip type: GeForce 8500 GT
    Display Memory: 1523 MB
    Dedicated Memory: 243 MB
    Shared Memory: 1279 MB
    Current Mode: 1680 x 1050 (32 bit) (59Hz)
    Monitor Name: HP w2207 Wide LCD Monitor
    Monitor Model: HP w2207
    Monitor Id: HWP26A9
    Native Mode: 1680 x 1050(p) (59.954Hz)
    Output Type: HDMI
    Driver Name: nvd3dumx.dll,nvd3dum,nvwgf2umx.dll,nvwgf2um
    Driver File Version: 8.15.0011.8171 (English)
    Driver Version: 8.15.11.8171
    DDI Version: 10
    Driver Model: WDDM 1.1
    Driver Attributes: Final Retail
    Driver Date/Size: 2/26/2009 19:21:00, 7826944 bytes
    ----------------------------------------------------------------------
    I heard about someone with a similar problem with Warcraft 3 and they said they had to switch their monitor from running 75Hz to 60Hz. They recomended to use a program called "RefreshLock", I tried that and it comes up "75Hz" as default, but I try switching it to a "60Hz" and the same problem occurs. I also tried "1680x1050 - 32BPP on 59Hz" and "1680x1050 - 32BPP on 60Hz", nothing. The above stats says I'm running "59Hz" which is probably true, but if it is shouldn't Warcraft 3 be running normally like it does on Vista Ultimate which is on the same machine? I have no idea what could be causing this, or more importantly how to find out (or change) what Hz I'm running on with this monitor besides using the "RefreshLock" program which seems to work fine (changing the resolution anyways). Other games run fine, Diablo II and Fallout 3 are both working. I'm starting to think this is either a problem with Windows 7 or the "prerelease" driver for Windows 7 by NVIDIA, though I don't see why it would only be causing problems with Warcraft 3 and not other games. It's also weird that the intro movie loads fine, but only crashes my monitor once the menu system tries loading. I tried running "640x480 - 32 BPP at 59 (and 60)" and running Warcraft 3 at 640x480 resolution, nothing. Any ideas?

    Oh yeah, I've also turned off sleep in the display mode under the power saving options, but the game still puts my monitor to sleep.
     
    #3 MikeAlex, Mar 9, 2009
    Last edited: Mar 9, 2009
  4. ChampDotA

    ChampDotA New Member

    Joined:
    Mar 9, 2009
    Messages:
    4
    Likes Received:
    0
    There can be many options of what the problem is.


    1. Your card is too old, cards over 9 months old normally don't last much longer unless you have a good cooling system.
    2. In Control Panel, open up Power Options and change the Turn Off Monitor tick box. (Create New Plan Settings)
    3. Try going to your control panel - power options and set the values : system standby : never Turnoff monitor : never
    4. Make the screen resolution for both the same. (Screen and the game)
    Maybe one of these will fix the issue. Also use google! type something like "game sets monitor to sleep" etc etc
     
  5. MikeAlex

    MikeAlex New Member

    Joined:
    Mar 8, 2009
    Messages:
    16
    Likes Received:
    0
    No, other older and newer games are working fine so it's not my card. I did the power options thing. Tried making a new power option. Tried the same screen resolution, and google'd the problem and tried all that (even tried the 'Vista' fixes). I even went as far as formating my harddrive and reinstalling Windows 7. Just looks like Warcraft 3 is now unplayable on my system.... -_-' I think it has something to do with it not being able to play on NT systems, but the WinXP SP2 compatability doesn't work either... Thanks anyways.
     
    #5 MikeAlex, Mar 9, 2009
    Last edited: Mar 10, 2009
  6. zerkz

    zerkz New Member

    Joined:
    Mar 10, 2009
    Messages:
    8
    Likes Received:
    0
    I run WC3 Flawlessly. You say it puts your monitor to sleep. Are you sure your Vid Card isnt imploding at that time? Moniters will go into sleep/no signal mode if it is not retrieving data from the DVI/VGA port.
     
  7. MikeAlex

    MikeAlex New Member

    Joined:
    Mar 8, 2009
    Messages:
    16
    Likes Received:
    0
    Yes! I got it working. For some reason Warcraft III won't run in HDMI, but when I hooked my monitor up to the VGA cable it works! Thanks for the VGA idea. :D It's a little anoying to have to switch back and forth to if I want to play Warcraft III, but it's well worth the game.
     

Share This Page

Loading...