What caused DistributedCOM Error

Discussion in 'Windows 7 Software' started by KCav, Mar 9, 2012.

  1. KCav

    KCav Senior Member

    Joined:
    Jan 4, 2009
    Messages:
    145
    Likes Received:
    0
    Event Viewer is reporting Error 10016 - application specific permission not granted to user S-1-5-18.

    I am logged on as an Administrator not a User. Why does EV think permission needs to be granted to a user not on the machine? S-1-5-18 is a generic SSID for a User? :confused:

    KC
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    That number represents the System. Are you running any wireless multi-function printers?

    Do you have more info, such as the GUID number for the AppID and the other number that shows?
     
  3. KCav

    KCav Senior Member

    Joined:
    Jan 4, 2009
    Messages:
    145
    Likes Received:
    0
    Yes I have a wireless laser printer on my LAN. The printer is made by Brother, model HL-2170W. It was installed by using a setup facility on the Brother website.


    COM server application CLID is C97FCC79-E628-407D-AE68-A06AD6D8B4D1
    and the APPID is 344ED43D-D086-4961-86A6-1106F4ACAD9B

    Ken
     
    #3 KCav, Mar 11, 2012
    Last edited: Mar 11, 2012
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    As I understand it, wireless devices, such as printers, are accounted for on a Virtual PCI bus. IPBusEnum is used to do this, and for some reason it requires, but was not given, local launch permissions.

    So, we can try this procedure, and I will do it on my Windows 8 install to see if we can get the messages to stop. Microsoft seems to feel the messages are not important, so it is up to you.

    First, use Winkey+R to open a run command (or start menu search box) and type dcomcnfg to open the snap-in.

    Open the Computers folder in the second pane.

    Right click My Computer and select properties and then the Com Security tab.

    We are looking for Local Launch permissions, and make sure your message agrees. The bottom half of the dialog window concerns this, so click Edit Default. Then click Add so you can add the local service. Type Local Service in the box and click OK.

    You should now be back in the Default Security tab with a LOCAL SERVICE user with Local Launch checked. Since I am doing the same thing you are, I will leave mine here and see if it helps. So just OK back out of the dialogs.

    You may need to reboot, but see if this stops the messages. If it doesn't, you might try adding more permissions (keep track of changes) beside Local Launch Default Security. I will do the same thing and post back if I find a setting that stops the messages.

    Let us know, and keep track of the instructions so you can make the alterations. The Help and Support section also has a section on DCOM and configuration or management.
     
    1 person likes this.

Share This Page

Loading...