Win 7 64bit install error 0xc0000005

Discussion in 'Windows 7 Installation' started by Norguaard, Oct 29, 2009.

  1. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    My file in Win 7 is 625 K. There was some talk about viruses being associated with a file like that, but without the 32. If you do a search for the file, does the archive show the same size as the one in the system32 folder? If it was different, the system file scan should have caught it.

    You could probably find somewhere to explain how to replace a file and I will check on it. You may have to take ownership to change it.

    Have you run any other type of anti-virus scans?
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I should note my files are on a 32 bit system, so the size may be different. My Vista advapi32.dll file is 782K.
     
  3. Norguaard

    Norguaard New Member

    Joined:
    Oct 29, 2009
    Messages:
    22
    Likes Received:
    0
    My ADVAPI32.dll file is 1041kb. I only did virus check with AVG free.
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Well, I hate to be the bearer of bad news. I just installed Vista x64 and AVG Free Anti-virus 9.0. I then uninstalled the AVG anti-virus as you said you did. I did an in-place upgrade from Vista to Windows 7 and had no problems or hangs durings the install. In my setupact.log file I have no reference to the avdapi32.dll file that seems to be giving you problems. I can only assume it is some other program you installed.

    The AVG free anti-virus you said was challenged by the compatibility checker was not challenged by mine, but I was using version 9.0 , which is supposedly fully Windows 7 compatible.

    It bothers me you say the Free version of AVG was not compatible, which would indicate to me you were using an earlier version and should have updated to the latest. You also say your virus scans do not complete, so maybe the update will allow you to track down any problems. Hopefully the earlier version did not leave reminents on your system, but check msconfig.exe to make sure something is not left of the earlier version, especially in the startup tab, prior to installing the newest.

    My final suggestion, and believe me, I have no more :frown: , is that you install the 9.0 version of the AVG free anti-virus and do a virus scan. If it does not complete, then that is most likely your problem, and I now know you can tell exactly where it stops. After taking care of whatever is causing the anti-virus scans to stop, then try to install again. I am sorry I could not help you find your problem.
     
  5. Norguaard

    Norguaard New Member

    Joined:
    Oct 29, 2009
    Messages:
    22
    Likes Received:
    0
    Thanks for trying, I appreciate it very much

    Thanks for all of your suggestions, Salt.

    I had installed version 9 of AVG free yesterday and was able to run a complete scan today, but nothing of significance was discovered. I think you are right, there is some program somewhere that is causing my headaches. I am going to stay with Vista for the near future, until I can get a second hard drive and try installing Win 7 on it along side my vista drive. If I can do that, I will transfer the files over from Vista and then wipe that drive. Sounds like an awful lot of hassle for what was supposed to be a simple upgrade, especially after I purchased the ultimate upgrade and did not use the Home Premium I had also bought. If I had intended to do a clean install I could have saved over $200. Oh, well, live and learn. Microsoft is just not able to do what they would like. They will never be as error-free as Mac. I can't afford to go back to Mac but I sure do think about it a lot.

    Once again, I appreciate your time and help.
     
  6. joepilot

    joepilot New Member

    Joined:
    Nov 25, 2009
    Messages:
    2
    Likes Received:
    0
    Same thing

    I have tried to upgrade an HP 64bit Vista machine to Win7 and have the same error as you and it fails at 85-86%. I've tried all kinds of things and burned the installation to a DVD but I always get the same result.

    00005994). Minidump attached (101137 bytes).
    2009-11-25 10:23:45, FatalError [0x090001] PANTHR Exception (code 0xC0000005: ACCESS_VIOLATION) occurred at 0x000007FEFF665994 in C:\Windows\system32\ADVAPI32.dll (+0000000000005994). Minidump attached (101409 bytes).

    I also deleted ADVAPI32.dll and I still got an access violation, which is odd. At the moment I am out of ideas.
     
  7. vsbala

    vsbala New Member

    Joined:
    Dec 30, 2009
    Messages:
    2
    Likes Received:
    0
    I also had the same problem like while expanding or completing the installation. But my problem was solved this way. I removed all USB drives/ports including (the front panel) via headers, USB keyboard/mouse, anything related to USB. The installation sailed peacefully. Just attempt this.
     

Share This Page

Loading...