Windows 10 Version 1511 - No Internet connection

#1
We have two 64-bit Windows 10 installations; one on an almost new i5 desktop and the other on a 2009 Dell Studio laptop. Whilst Windows 10 Version 1511 OS Build 10586.36 works OK on the desktop PC, on the Dell laptop there's no Internet connection if I try & install the same version / build. It comes up with the error message: "One or more network protocols are missing on this computer".

I have tried installing it twice, but get the same error / no connection both times. The network function reports that IPv4 is connected to the Internet but that IPv6 connectivity has no network access.

Does anyone know how to fix this error? For now, I have re-installed the previous version from the image I fortunately made a couple of weeks ago and set Windows 10 to accept critical updates only. As soon as this was installed, the laptop jumped back into life.

Once again, it is an example of lack of full testing at Microsoft!
 


Josephur

Windows Forum Admin
Staff member
Premium Supporter
#2
I have seen this exact error before unfortunately I forget the fix. If I think of it I will post back (but it's doubtful).
 


#3
Thanks for letting me know Josephur. Hopefully somebody else has too and can remember the fix!
 


Josephur

Windows Forum Admin
Staff member
Premium Supporter
#4
Which Dell Studio machine is it?
 


#5
It's a 17" Studio1555 Model PP39L. Built in 2009
 


Josephur

Windows Forum Admin
Staff member
Premium Supporter
#6
Lets answer some questions so that someone might be able to help you better.

Are you talking about the LAN connection or wireless?

Is the BIOS updated to the latest version? (A12 in this case)

Is the network card visible and installed correctly in device manager?

If the card is visible in device manager, have you attempted to uninstall it and let Windows reinstall it?

Which network card does your system have? (The Dell driver download page shows several possibilities)

Have you tried locating the latest driver for said network card directly from it's manufacturer? It does not look like Dell will support Windows 10 officially on this machine, nor release driver updates from the product's support page.
 


#7
Hi again Josephur

I'm talking about a hard-wired LAN connection

The BIOS is as it was originally in 2009. How do you (a) find out what it is and (b) update it with the correct version for this PC?

In the Device manager window, the following network adapters / drivers are reported as being present and working correctly:
Broadcom Netlink Gigabit Ethernet
Intel WiFi Link 5100AGN
WAN Miniport (IKEv2)
WAN Miniport (IP)
WAN Miniport (IPv6)
WAN Miniport (L2TP)
WAN Miniport (Network Monitor)
WAN Miniport (PPP0E)
WAN Miniport (PPPTP)
WAN Miniport (SSTP)

I haven't tried un-installing any of them, but when I go back to the earlier version of Windows 10, (via a previous image) everything works as it should.

Piriform Speccy reports the network card as being a Broadcom Netlink Gigabit Ethernet (as above)

No, I haven't tried searching for new drivers, since up until the latest Windows 10 update, everything has worked fine. Thanks for the tip that Dell aren't supporting Windows 10 on this PC.

Do you have any suggstions as to what else I might try, or should I just stay with the current Windows 10 version and ignore all the 'fancy stuff' Microsoft are adding? (Which my wife probably doesn't want anyway!)
 


drojas4

Well-Known Member
#8
I have 2 Asus laptops that I get the same error all I do is rest the cable modem and it works great for a few weeks , then I have to rest set again.
Yep it all started with Windows 1511.
My cable modem has the build in router.
 


Josephur

Windows Forum Admin
Staff member
Premium Supporter
#9
You could try the latest driver that Dell has for that network card (even if its for Win7/8). Install it in compatability mode, it may make the device work.
 


#10
I'll do that Josephur. I also checked the Dell website for a BIOS update. The A08 BIOS I have was created in July 2009. It was updated in November 20009 and then again in 2011. This was the last (and it seems only the second) time it was updated.

Is there a way to save the current BIOS in case the update doesn't work? (i.e. Similar to the 'roll-back' you can do when updating drivers?)
 


Neemobeer

Windows Forum Team
Staff member
#11
This sounds like an issue with the modem/router. Even if you have no internet connection you should be able to remote into the modem and look at the status page to see if the external link is operational.
 


#12
I think the modem router is OK Neemobeer, as two other PC and two tablets work through the same router (as well as a Smart TV). They are all working OK.
 


join8x

New Member
#13
Thank you.
 


Last edited by a moderator:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.