Windows 7 does not recognize my external HDD

#1
When I plug in my external HDD I hear the USB noise, but it does not show up under My Computer. It does however show up and it allows me to safely remove the device, though it doesn't have the original device's name (FlexDrive). So instead of "Eject Flexdrive" it says "Eject External".

I've been having this problem with this HDD for a while now, but I would just eject it and plug it back in and it would recognize. This time it was a different story, it is not recognizing, even though it lights up and the disk starts to spin.

This is what disc management shows as well (also showing what I meant when trying to eject):
 


Captain Jack

Extraordinary Member
#2
Hello !! Welcome to Seven Support Forum !!

Looking at your Disk Management 149.05 GB is unallocated you might wanna format it and make it as health partition. Follow these steps

  1. Right-click on the Unallocated hard disk space
  2. Select New Simple Volume in the menu options
  3. The New Simple Volume Wizard will appear. Click the Next button to start the wizard
  4. Specify the volume size. The Wizard defaults to the maximum. When finished, click Next
  5. Assign a drive letter or path, by default, the wizard will assign the next logical drive letter. This will be the best option for most users. Click Next
  6. Format partition. By default the wizard will select NTFS with Default selected as allocation unit size. This is recommended for most users. The user also has the option of creating a volume label in the text box. Quick format is selected by default. Click Next
  7. The Wizard will list the selected settings. Review the settings and click Finish
When the new disk partition is complete, a new empty window will appear on the desktop. The partition is formatted and ready for data storage.



Hope this helps,
Captain
 


#3
I don't have those options when I right click.
This is what I get:
 


#5
Oh man, I don't want to make a new partition on this drive. And like I said, it used to work (it was working last night, for that matter), so I don't know why it's showing up as unallocated.

EDIT: lol, for example right now. I just ejected it and plugged it in again and autoplay came up... =/

EDIT2: And now that I have it working, this is what it looks like:
 


Last edited:

Captain Jack

Extraordinary Member
#6
Maybe something wrong with the cable itself ... Glad that you got it working !! You might wanna consider running a diagnostic on the Hard drive because it's not a good acting like this.

Good Luck,
Captain
 


#7
How would I go about running a diagnostic?

EDIT: BTW, this is what disc management looks like when it is working:
 


Last edited:

Captain Jack

Extraordinary Member
#8
Hello,

Follow this link Hardware Diagnostic !! there it will mention about Hard Drive Diagnostic

Good Luck,
Captain
 


#9
The command 'chdkdsk G:' found no problems.
 


Captain Jack

Extraordinary Member
#10
Go to the manufactures website there you'll find a Diagnostic Tool mostly a bootable one download that and run it. Also consider changing the cable.

Good Luck,
Captain
 


#11
Manufacturer of the PC or the HDD?
 


#13
Well, I can't tell because I won this HDD from a program Microsoft holds called Club Bing, and the only logo on it is the Bing logo... =/
 


#14
Try updating the drive firmware.
 


#15
Alright, well just updating: the drive totally died a few days ago, and I sent it in for RMA, when I get it back I will be replacing the RMA'd drive with my laptop's internal drive.

If you want to help me with that please go to this thread.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top